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1 Symbols on the equipment 
The following symbols may be used on the labels and in the manuals. Familiarize yourself with each 
symbol and its meaning before operating the MEG system. 

Table 1: List of symbols on the equipment. 

Label Meaning 
 

 

Caution. Parts of the system are marked with this label when it is necessary to draw the attention of the user to 
avoid a potential hazard or to ensure safe, correct or improved operation or to avoid damage. 

 

 

Refer to the instruction manual. Parts of the system are marked with this symbol when it is mandatory for the 
user to refer to instructions given in the manuals accompanying the system to ensure safe operation. In the 
manuals, it also calls attention to these instructions. 

 

 

Consult instructions for use. Parts of the system are marked with this symbol when it is necessary for the user 
to refer to instructions given in the manuals accompanying the system. In the manuals, it also calls attention 
to these instructions. They are intended to ensure correct or improved operation and/or increased safety or to 
avoid damage. 

 

 

Type BF (body floating) equipment symbol. The applied parts (parts in direct contact with the person being 
investigated with the system) and the type plate are marked with this symbol to indicate that they fulfill the 
leakage current requirements of the safety standard IEC 60601-1. 

 

 

Alternating current (power line) symbol. 

 

 

Protective ground (earth) terminal symbol. Used to identify terminals which are intended for connection to an 
external protective conductor for protection against electrical shock in case of a fault, or to the terminal of a 
protective ground (earth) electrode. 

 

 

Static electricity symbol. The parts of the system marked with this symbol indicate the presence of 
components susceptible to static electricity and require the use of special static-electricity preventing 
techniques. 

 

 

Non-ionizing radiation, RF transmitter. Marking on equipment or equipment parts that include RF transmitters 
or that intentionally apply RF electromagnetic energy. 

 

 

Disposal instruction symbol. Separate collection of waste electrical and electronics equipment (WEEE) 
necessary (European Union directive 2012/19/EU on WEEE). 

 

 

Name and registered address of the manufacturer, optionally combined with date of manufacture (year 
followed by month and day, if applicable). 
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Date of manufacture: year (four digits) followed by month and day (if applicable). 

 

 

Model or type number. 

 

 

Serial number. 

 

 

Medical device. 

 

 

Unique device identifier. 
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2 Introduction 

2.1 Scope 
This document presents the basic pre-processing and analysis steps for functional mapping and 
epilepsy source localization for MEG data collected with TRIUXTM or TRIUXTM neo systems.  

The content is divided into sections which allows the user to first learn the basic steps and then build 
on that knowledge with additional topics. This document is intended to provide step-by-step guidance 
using the Data Analysis Software Release 3.4. Throughout this document, the software will be referred 
to as Data Analysis Software or DANA. 

The data analysis steps described in this document aim to follow the conventions and 
recommendations presented in American Clinical Magnetoencephalography Society Clinical Practice 
Guidelines (https://www.acmegs.org/clinical-resources/practice-guidelines) and it is recommended 
that you get familiarized with the following guidelines before starting to use the DANA software: 

• American Clinical Magnetoencephalography Society Clinical Practice Guideline 1: Recording 
and Analysis of Spontaneous Cerebral Activity.  

• American Clinical Magnetoencephalography Society Clinical Practice Guideline 2: Presurgical 
Functional Brain Mapping Using Magnetic Evoked Fields.  

• American Clinical Magnetoencephalography Society Clinical Practice Guideline 3: MEG-EEG 
reporting. 

• American Clinical Magnetoencephalography Society Clinical Practice Guideline 4: 
Qualifications of MEG–EEG Personnel. 

Learning to use the DANA software for analyzing patient data requires that the user already has 
sufficient clinical background, or that the learning is supervised by a trained clinician. Guideline 4 states 
that “Specific MEG training should also include supervised learning of and practice in clinical MEG 
recording, reviewing, and source analysis of clinical MEG for at least 6 months and the independent 
interpretation and reporting of at least 50 MEG studies of epilepsy and 25 MEG studies of evoked fields 
(auditory, visual, somatosensory, motor, and language). The majority of epilepsy studies should be 
abnormal and include a mixture of clinical findings.” 
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2.2 User roles 

The following types of end-user profiles can be defined in MEG data acquisition and analysis: 

MEG technologist A person who performs the MEG acquisition.  

MEG analyst A person who performs the MEG data analysis.  

MEG key user A person who performs routine and emergency 
administrative (IT, electrical) operations on the MEG 
system.  

Neurosurgeon A person who operates patients to treat epilepsy or other 
neurological disorders. Uses MEG results to guide the 
operation. 

The instructions in this guideline manual are targeted mainly for customer training of MEG 
technologists, MEG analysts and MEG key users. 

Note that the roles of MEG technologist and MEG analyst vary according to the site. In some clinics, 
MEG technologist does only the MEG measurement, in some clinics MEG technologist does 
preparatory steps of the analysis, and in some, the MEG technologist does the entire analysis and a 
MEG doctor (MEG analyst in this terminology) approves the results. 

 

2.3 Data Analysis Software 
The Data Analysis Software (DANA), once installed on a workstation, is a group of software applications 
designed to perform the necessary tasks for MEG data analysis. They can all be started from the 
Neuromag menu under Applications in the toolbar. You can also drag each icon from the Neuromag 
menu to your Desktop if you wish to start the application from a Desktop icon. 

Some applications can be referenced two ways, for example, SourceModelling application starts the 
Xfit software, and may be used interchangeably.  

The software applications and their naming conventions are: 

 
 
Figure 1: DANA software modules. 

• DicomAccess – Import MRI 
• Graph – Review raw data, perform spectral analysis, mark events 

(e.g. spikes) 
• GraphicsClipboard (Cliplab) – Capture and print results for reporting 
• MaxFilter – Suppress interference, compensate for head movement 

and average pre-processed data 
• MEG-MRI-Integration (Mrilab) – Co-register MRI images with MEG 

head coordinate frame, overlay and export fitted dipoles 
• MRI-segmentation (Seglab) – Segment brain surfaces 
• Plotting (Xplotter) – Explore responses at the sensor level 
• SourceModelling (Xfit) – Apply spherical or BEM head models and 

compute single- or multidipole source models 
• ViewBrain – View segmented surfaces (not covered in this manual) 
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Detailed technical documentation of the Data Analysis Software modules is included in the manuals:  

NM20568A-* Source Modelling Software User’s Guide 
NM10238A-* Data Plotting User’s Guide 
SW21301A-* DICOM Access User’s Guide 
NM20419A-* Mrilab User’s Guide 
NM20420A-* Seglab User’s Guide 
NM20421A-* Cliplab User’s Guide 
NM10239A-* Signal Processor User’s Guide 
NM10240A-* Signal Processor Reference Manual 
NM24057A-* MaxFilter 2.2 User’s Guide (not USA) 
NM24124A-* MaxFilter 2.2 User’s Guide (USA only) 
NM25410U-* Addendum to MaxFilter™ 2.2 User’s Guide: Individual MEG Channel Artifacts  
NM21902A-* ViewBrain User’s Guide 

Printed manuals can be found in the manual binders. The manuals in pdf form documents are 
accessible in the directory /neuro/manuals after the Data Analysis Software has been installed in 
the analysis workstation.  

 

The manuals contain important hazard information which must be read, understood and 
observed by all users. General limitations of the programs are included in the following 
Chapters. For your convenience all warnings that appear in the manuals are presented in the 
appropriate sections of this manual. 

 

2.4 FIFF file naming 
The primary file format in DANA software modules is FIFF (Functional Image File Format), a proprietary 
file format of MEGIN. The MEG data files have typically the following extensions: 

_raw.fif   unprocessed raw continuous data file 
_raw_sss.fif  MaxFilter -processed files (spatial SSS) 
_raw_tsss.fif  MaxFilter -processed files (spatiotemporal SSS, tSSS) 
_raw_mc.fif  MaxFilter -processed files (movement compensation and SSS) 
_raw_tsss_mc.fif  MaxFilter -processed files (tSSS and movement compensation) 
_ave.fif  averaged data files 
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2.5 Training data 

The instructions in this document refer to a specific training demo data set which is described in 
NM26084D-* MEG Training Dataset Specification. The demo data set represents:  

1. Spontaneous and evoked field recordings from a healthy case subject.  
Spontaneous recordings were performed with eyes open and eyes closed conditions. The 
evoked field stimuli were designed to probe mainly the primary sensory areas so that the data 
are relatively straightforward to analyze. Continuous raw data includes continuous head 
position indicator (cHPI) signals. Maxfilter can be applied for pre-processing continuous data 
for interference suppression (tSSS and SSS), as well as movement compensation. 

2. Simulated interictal epileptic activity. 
The spontaneous data recording from the healthy case was used as basis for adding simulated 
interictal spike activity. The simulated data can be used for training of the various software 
modules in analyzing interictal epileptiform activity.  

Please note the paths stated in the document (i.e. /neuro/data/…) are for example only. Actual data 
location may be different for each site. 
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3 MEG analysis workflows  

3.1 Workflow for functional mapping 
Modelling averaged evoked-response field (ERF) data with current dipoles is one way to perform 
functional mapping. According to the American Clinical Magnetoencephalography Society Clinical 
Practice Guideline 2: Presurgical Functional Brain Mapping Using Magnetic Evoked Fields, the following 
fields can be evaluated with spherical head models. 

• Somatosensory Evoked Field (SEF): average 100-300 trials per stim location, high-pass filter 
[1,20] Hz, low-pass filter [40,100] Hz, localize N20m and/or P35m. 

• Motor Related Field (MEF) finger tapping: average 50-100 trials, band-pass filter [1,25] Hz, 
localize movement related field [30,40] ms before movement onset. 

• Auditory Evoked Field (AEF): average ~100 trials, band-pass filter [1,30] Hz, localize N100m. 
• Visual Evoked Field (VEF): average 100-200 trials per stim location, high-pass filter [1,9] Hz, 

low-pass filter [50,100] Hz, localize P100m.  

 
Figure 2: Recommended workflow for functional mapping. 

The following workflow is recommended for basic functional mapping using the DANA software: 

1. Prepare MRI and single sphere head model, Section 4. 
2. Pre-process raw recordings of SEF, MRF, AEF and/or VEF using MaxFilter, Section 5. 
3. Prepare events for functional mapping, Section 6. 
4. Perform source modelling and display the best fitting dipoles on the MRI, Section 8. 
5. Prepare DICOM export and clinical report, Section 9. 
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3.2 Workflow for epilepsy source localization 

According to American Clinical Magnetoencephalography Society Clinical Practice Guideline 1: 
Recording and Analysis of Spontaneous Cerebral Activity: “Evaluation of a magnetic isofield map at 
selected time points is necessary for estimating the number of generator sources and their spatial 
distributions. These maps will vary with the type of sensor coils in a particular MEG system. When the 
magnetic isofield map at a selected time point contains a single, distinctive, dipolar pattern, a single 
ECD can be used to estimate the generator source. Multiple ECD analysis may have to be implemented 
if more complex fields are evident. It is useful to view maps sequentially over the time course of the 
spike. If during a single phase of the spike, its magnetic field increases and decreases but does not 
rotate or change the shape, then one can assume a stable MEG source. If the field rotates during a 
single spike phase, the MEG source may be propagating”. 

 

 
Figure 3: Recommended workflow for epilepsy source localization using the DANA software. 

The following workflow is recommended for spike localization using the DANA software: 

1. Prepare MRI and single sphere head model, Section 4. 
2. Pre-process raw recordings of SEF, MRF, AEF and/or VEF using MaxFilter, Section 5. 
3. Prepare events for source localization of epileptiform activity, Section 7. 
4. Perform source modelling and display the best fitting dipoles on the MRI, Section 8. 
5. Prepare DICOM export and clinical report, Section 9. 
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4 Prepare MRI and sphere model 
This section presents the steps needed to import MRI data to the MEG data analysis workstation or 
file server, co-registering the MRI images with the MEG head coordinate frame and define a sphere 
model origin with Mrilab. 

In general, 
• The MRI should have T1-weighted contrast. 
• It should have close to isotropic voxel size (preferably around 1x1x1 mm).  
• The image should contain as little spatial distortion as possible. 
• The patient should have been as fixed as possible to reduce movement artifacts. 

 Figure 4: Workflow steps for preparing MRI and sphere head model. 

4.1 Import MRI with DicomAccess 

 Start the program 

Launch Applications -> Neuromag toolbox -> DicomAccess (Figure 5). 

 

Figure 5: DicomAccess user interface. 

 Get the DICOM slices 

• Change Source: Directory and navigate to the DICOM slices:  
/neuro/data/demo/mri/slices.  

• Double-click the series which contains the 3D-volume T1 images of the whole head. If the 
slices are read without errors, you can see information of the slices (Figure 6). 
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Figure 6: Importing DICOM data from the source directory. 

 

 

 

• If the DICOM slices are not read correctly and you see error messages, you can try to change 
the settings to ‘DICOM Part 10’, ‘Ignore VR mismatches’, ‘Ignore missing values’, and try 
again (Figure 7). 

 

Figure 7: DicomAccess parameters. 
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 Transfer the slices and sets to the storage volume 

• Note that the demo data set images are used both for research and simulated epilepsy cases.  
• Select GET, set the Destination directory to /neuro/mri/example_case/.  
• Select Create (Figure 8).  
• DICOM slices are saved in /neuro/mri/example_case/slices.  
• A FIFF file which has the links to individual slices is saved in 

/neuro/mri/example_case/sets. Note: this FIFF file contains only the link to the 
MRI data, it does not contain head position information from the digitized landmark and 
head surface points obtained during the MEG preparation. That information is stored with 
the MEG recordings for now. 

 

Figure 8: Set destination directory. 

 

4.2 Co-register MEG and MRI with Mrilab 

 Start the application MEG-MRI-Integration (Mrilab) 

• Launch Applications -> Neuromag toolbox -> MEG-MRI Integration. 
• Select File -> Preferences->General to adjust slice setup ‘Right on right’ or ‘Right on left’. 

 

 Load the MRI image (.fif) of the subject  

• Select File -> Open (Alt-f + o) and select the FIFF MRI-file 
/neuro/mri/example_case/sets/001_1_01.fif.  

• Click Apply on the pop-up window (Figure 9). 
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Figure 9: MEG-MRI Integration file loading. 

 Review the images 

• Adjust the contrast and brightness sliders at the lower right corner of the window (Figure 
10). 

• Select the Move Slice tool and scroll through the slices to review the subject’s anatomy. 
• The crosshair position is adjusted by keeping the left mouse button pressed and moving the 

cursor up and down in each window. Move the mouse pointer on 
o Left lower window for head-feet slicing. 
o Upper right window for left-right slicing. 
o Upper left window for anterior-posterior slicing. 
 

 

Figure 10: Mrilab user interface. The Move Slice tool is circled. 
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 Set the anatomical landmarks 

• Open Windows -> Landmarks (Figure 11). 
• Select the landmark to set by clicking in the X coordinate box, click Goto, adjust the crosshair 

to the proper location and click Get.  
• Repeat for all three landmarks. Be sure the landmarks are the same as those marked during 

digitization; refer to the photos if they have been taken during the preparation. 
• Select OK. 

 

Figure 11: Setting the landmark points. Note: selecting the Move Cross-section tool (circled) 
enables to grab and move the crosshair directly to a desired location. 

 

 Import digitized points from MEG file and check co-registration 

• Open File -> Import -> Isotrak data (Alt-f + i + i ) and select a FIFF file containing the recorded 
MEG data, e.g. /neuro/data/demo/example_case/190122/*.fif . Note: all the MEG 
data files from the same measurement session contain the same digitization info. 

• Click Make Points (Figure 12). 
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Figure 12: Import digitized points from a FIFF file. 

• Check that head shape points align with the head surface. If not, fine tune the landmarks 
until they do. This can be done in two ways: 
o Select the Move Slice tool and adjust the crosshair to the desired landmark location 
o Shift the landmarks by directly changing the coordinate values. To avoid rotation, change 

all the coordinates that are zero by the same amount for a given direction. 
• Select Apply to apply changes and OK to confirm and close the window. 

Save the co-registration for later use: Select File -> Save and navigate to the corresponding 
subject directory. The co-registration file will be named as NN-operators_name-date.fif, e.g. 
/neuro/mri/example_case/sets/001_1_01-meg-181001.fif. 

• Remove the head shape points: Objects -> Clear all -> Points.  
• Do not exit program yet! 
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4.3 Define sphere model origin with Mrilab 

 Mark the inner surface of the skull 

• Adjust the views and cursor so that the cursor is in the center of the head, see Figure 13. 
• Select the Point tool.  
• Hold the Shift key and click the images to make points around the inner skull. The points 

should cover the brain in several directions, leaving the bottom part without points.  
• It is recommended to obtain approximately 15-20 points per orthogonal plane (sagittal, axial 

and coronal; Figure 13). 
• Note: This is an important workflow step for defining the optimal origin both for the 

MaxFilter processing (section 5.4) and for source modelling (section 6.4). 

 

Figure 13: Fit a sphere on the point set. The Point tool is circled. 

 Obtain the best fitting sphere  

• Select Objects -> Fit sphere. 
• Locate and observe the center of the sphere, marked by a yellow triangle (Figure 13). 

Confirm the sphere is correctly placed over the brain, following the curvature of the skull. 
• Save sphere origin coordinates to a text File -> Export -> Spheres (Alt-f + e + s) or take a 

screenshot and save it with the dataset. 
• Note: If you launch SourceModelling (Xfit) or MaxFilter at this point, you can drag-and-drop 

(using the center mouse button at the label left to textboxes) or manually type the sphere 
origin coordinates directly to the origin setting dialog of the other application. 
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4.4 Head position inspection 

Correct head position information is crucial for the source modelling, because inaccurately determined 
head position can lead to incorrect localization of brain activity and subsequently to wrong diagnosis 
and treatment decision leading to incorrect resection of cerebral cortex. Therefore, it is recommended 
to inspect the head position visually before the MaxFilter pre-processing and source modelling steps. 

The most straightforward way to visualize the head position inside the MEG helmet is to launch the 
Source Modelling Software Xfit). Load the measured file in Xfit and select Overlay: Std head and 
Overlay: Isotrak in the bottom part of the main display (Figure 14; see also Source Modelling Software 
User’s Guide section 5.1). 

Note that you can open also a raw data file in Xfit; it can then load only HPI data, but the program 
shows both the digitized points and the head position. If the visual inspection shows a strange head 
positions, see Chapter 11 for more detailed instructions for trouble shooting and correcting the 
problem with a wrong head position determination.  

 
Figure 14: Visualization of the head position and digitized points in Xfit. 
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5 Pre-process raw data using MaxFilter 
MaxFilter software is intended to be used with the MEGIN products for suppressing magnetic 
interference coming from outside of the sensor array, reducing measurement artifacts, transforming 
data between different head positions, and compensating disturbances due to magnetized material or 
other close-by artifact sources on the head and due to head movements.  

The main functions of MaxFilter are 
• Signal Space Separation (SSS) for suppressing external interference. 
• Temporal SSS (tSSS) for suppressing close-by interference. 
• SSS-based data transformation between head positions1. 
• SSS-based head movement compensation2. 

This section presents the default use of MaxFilter. See Section 12 and MaxFilter User’s Guide for more 
detailed description of optimizing the MaxFilter processing.  

 Figure 15: Workflow steps for MaxFilter preprocessing. 

5.1 Start MaxFilter 

• Launch Applications -> Neuromag -> MaxFilter. 

 

Figure 16: MaxFilter launching and the main GUI display. 

 

 
1 SSS data transformation between head positions is not approved for clinical use in USA. 
2 Movement compensation is not approved for clinical use in USA. 



22 
 

5.2 Load data and select tasks 

• Select File -> Load data... (Alt-f + l) browse to the folder and select 
/neuro/data/demo/example_case/190613/*_raw.fif  
Note: the subject had a magnetized tooth which created movement-related artifacts. 
Therefore, tSSS is needed to suppress such nearby artifacts. 

• File selection and the Maxwell filtering default tasks are depicted in Figure 17. 
• The basic SSS is always included when tSSS and/or movement compensation are performed. 

If MaxFilter detects that there are no disturbance waveforms to be projected out, tSSS 
automatically transforms to the spatial SSS. Therefore, tSSS can always be selected even if 
there were no magnetized material or head movements in the recording. However, tSSS 
processing takes longer time than the basic SSS.  

• Select OK to close the file selection dialog. 

 

Figure 17: Selecting the input file and Maxwell filtering tasks. When continuous HPI was used, the 
recommended task is Movement correction with tSSS. Otherwise, you can always select the 
Spatiotemporal tSSS task without any head position task.  

  

The following default tasks will be used for each file: 

File Maxwell filtering 
task 

Head position 
task 

*01_raw.fif 

Continuous HPI was not 
used. 

Spatiotemporal 
tSSS 

No head position 
estimation 

*02_cHPI_raw.fif 

Continuous HPI was 
active. 

Spatiotemporal 
tSSS 

USA version: Head 
position 
estimation 

Non-USA version:  
Head movement 
compensation 
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5.3 Load fine-calibration and cross-talk correction files  

• This step is not necessary if MaxFilter is being applied to data that was collected locally – the 
default files are already stored in the system: /neuro/databases/sss/* with a name that 
indicates the site and used by MaxFilter by default. 

• When using data not recorded on the local system, it is necessary to change the fine-
calibration and cross-talk correction files. These should always be supplied with external data 
(by the lab that supplied the data), as is with the demo data. 
o Select Parameters -> Fine-calibration… (Alt-p + f), select 

/neuro/data/demo/example_case/190613/sss_cal_3142.dat 

o Select Parameters -> Cross-talk correction… (Alt-p + c), select 
/neuro/data/demo/example_case/190613/ct_sparse_triux2.fif 

o This needs to be done every time a new dataset is loaded for pre-processing. 

 

5.4 Set SSS expansion origin  
For optimal SSS performance, it is recommended to find the sphere origin from MRI data (see 
Section4.3.2) and provide the coordinates before processing. 

• The default origin is [0,0,40] mm. 
• Select Parameters -> Origin… (Alt-p +o) and enter the coordinate from Mrilab, screenshot or 

notes, or drag and drop from Mrilab (see section 4.3).  

5.5 Detect and correct bad channels as needed 
Bad channels are excluded from MaxFilter processing. The data on the bad channels is reconstructed 
from the information on all other channels. 

• Automatic detection: MaxFilter can detect automatically if there are MEG channels with 
spurious sensor artefacts that need to be excluded in SSS processing.  

• Manual detection: the automated bad channel detection may fail to recognize an abrupt 
artifact on a single MEG channel. In such cases, MaxFilter processing spreads the channel 
artifact on multiple channels in vicinity of the affected one. Therefore, it is important to 
inspect the raw data to which MaxFilter processing was applied. If a suspected artifact 
activity is present only on a single MEG channel in the raw data, it is most likely a channel 
artifact and the channel must thus be disregarded. Known and suspected bad channels need 
to be manually marked as bad ones, using Parameters -> Bad channels… (Alt-p + b)  
o See NM25410U-* “Addendum to MaxFilter™ 2.2 User’s Guide: Individual MEG Channel 

Artifacts — A Case Example” for more details. 
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5.6 Execute MaxFilter processing 

• Select Execute in the main window.  
• MaxFilter now processes the loaded file and generates a new file. In the example of Figure 

17, the output file is jn_sef_eo_02_chpi_raw_tsss_mc.fif. 
• Observe the progress by viewing the output log: File -> Show log… 
• When head positions are estimated for movement compensation, observe the head 

positions by selecting Display ->Head positions… (Alt-d + h) (Figure 18).  
• Each file should be loaded and executed to result in the following output files in directory 
 /neuro/data/demo/example_case/190613: 
 *_raw_sss.fif, *_cHPI_raw_tsss_mc.fif 

 

Figure 18: MaxFilter head position display and log window for the example case of Figure 17. 
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6 Prepare events for functional mapping 

 Figure 19: Workflow for preparing events for functional mapping. 

6.1 Re-average pre-processed evoked response data 
According to ACMEGS Clinical Practice Guideline 2, off-line averaging after data acquisition allows for 
noise-reduction processing (i.e. MaxFilter), elimination of artifact-containing traces and judicious 
selection of band-pass filtering. 

• After processing continuous evoked data with MaxFilter, re-average the events to create a 
clean evoked file. 

• In MaxFilter, select Averager -> Load raw data… (Alt-a + l), and select the continuous 
MaxFilter -processed data (*_raw_tsss_mc.fif or *_raw_sss.fif). 

• Optionally, you can define the output filename using Averager -> Output file… (Alt-a + o) and 
adjust rejection limits using Averager -> Rejection limits… (Alt-a + r). 

• Press Execute. 
• The result is saved alongside the original with extension *_ave.fif. 
• Note: baseline correction is not applied to the average. It is recommended that baseline 

noise estimation and correction is used during source modelling in Xfit. 

6.2 Explore evoked responses at the sensor level with Xplotter 
Plotting (Xplotter) module allows you to view the readings of each sensor plotted against time, and to 
measure latencies and amplitudes of responses. It is possible to view several data sets simultaneously, 
so that the plots are superimposed on top of each other. For this section, we will use the dataset 
/neuro/data/demo/example_case/190122.  
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 Launch Plotting (Xplotter) 

Select Applications -> Neuromag toolbox -> Plotting (Figure 20).  

 

Figure 20: Launching Xplotter. 

 Load two datasets that will be superimposed 

• Select File -> Load data (Alt-f + l) and select jn_vef_ave.fif. 
o Available data, select *>Vis ur>average.  
o How to load?, select Replace old data. 
o Time scale modification, select No time shift.  

• Select OK. The selected data is now visible in a topographical plot (Figure 21). 
• Select File -> Load data (Alt-a + l) and select jn_vef_ave.fif. 

o Available data, select *>Vis ul>average.  
o How to load?, select Overlay old data from viewport. 
o Time scale modification, select No time shift.  

• Select OK.  
• The second dataset is overlaid with the first one in the topographical plot (Figure 21). 

 

Figure 21: Xplotter data loading and overlaying. 
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 Review the display 

• The Xplotter display layout shows the channel-level epoch waveforms in a topographical 
view, nose up, right on right (Figure 21). The curves are organized in triplets, where the three 
channels are in the same physical location: 
o On the right-hand side of a triplet (Figure 22) you see the readings of a magnetometer; it 

measures the magnetic flux penetrating the sensor. Magnetometer channel numbers 
end with number one (e.g. 1741).  

o On the left-hand side of a triplet you see the plotted readings of two planar 
gradiometers. They are sensitive to two orthogonal components of the gradient of the 
magnetic field along the helmet surface. Gradiometer channel numbers end with 
numbers two or three (e.g. 1742 and 1743). 

 

 
Figure 22: MEG channel naming convention and triple-sensor layout. 

• Display the plot channel number: Click and hold the left mouse button over any plot. The 
channel number is displayed at the bottom of the window (Figure 22). 

• Display the cursor position: Click and hold the left mouse button over the plot. The time 
corresponding to the cursor position is displayed at the bottom of the window.  

• Display the amplitude: Click and hold the left mouse button over the plot. The amplitude at 
the time corresponding to the cursor position is displayed at the bottom of the window.  

• Zoom in: Select and hold the Shift key, then click and hold the left mouse button and drag 
over the area to zoom (Figure 22). 

• Zoom out: Select and hold the Shift key, then click left mouse button on any part of the 
graph. 

• Autoscale the time: Select Process -> Autoscale (Alt-p + a). 
• Autoscale the amplitude: Select Process -> Autoscale amplitudes (Alt-p + p). 

 Adjust the trigger-to-stimulus delay 

• You can adjust the trigger-to-stimulus delay in Xplotter and Xfit if it was not recorded into the 
acquisition parameters. The result will be that the zero timepoint will represent the onset of 
the stimulus.  

• The actual delay values are site and configuration specific and should be measured for all 
equipment at the time of install. 
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• To determine if the delays were recorded, read out the acquisition parameters from the FIFF 
file.  
o Open a system terminal: Applications -> System Tools -> Terminal. Type the command: 
 cd /neuro/data/demo/example_case/190122/ 
 /neuro/bin/util/show_fiff -vt150 *raw_sss.fif > temp.txt 

o Open the text file and scroll down to parameters ERFeventDelayNN and locate the event 
you are analyzing (ERFeventCommentNN contains the names of the stimuli). 

o If the field is 0, then the delay was not recorded and can be entered when loading a file 
to Xplotter or Xfit.  

• For the demo dataset, stimulus delay for visual is 33 ms and for auditory 6 ms. 
o Open the FIFF file again, File –> Load data, and select Absolute shift (see Figure 21).  
o Change the value of tmin manually to the required delay (e.g. 33 ms or 6 ms) and click 

OK.  
o When you have loaded the data, you can Autoscale the responses once again. 

 Adjust the filters 

• Select Process -> Filter… (Alt-p + f) (Figure 23a). 
• Select the Lowpass toggle and enter 40 Hz with a width of 5 Hz. 
• Select Rescale to see the effect of the current filters on a sample response. The original and 

filtered response are shown in the bottom row of the window.  
• Select Apply.  

 Set the baseline 

• Select Process -> Baselines… (Alt-p + b) (Figure 23b). 
• Select Use baseline toggle. 
• Enter Baseline start = -200, Baseline end = -5 (to avoid the trigger artifact). 
• Select OK. 

a)    b)     

Figure 23: Xplotter a) filter and b) baseline settings. 
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 Set operations 

• To see a list of loaded data sets and controls for changing their display, filters, baseline and 
SSP status (Figure 24). 

• Select Process -> Set operations... (Alt-p + o)   
• Load or delete the SSP projections for individual sets: Select Load projection… or Delete 

projection. Note that if the data has been MaxFilter -processed, it does not contain the SSP 
vectors anymore. 

• Create derivatives: In the expr field type arithmetic expressions for two or more sets. An 
expression is composed of operands and operators, separated by one or more spaces or 
tabs. An operator defines the operation to be performed on one or two operands. The 
operands are entered before the operator: 
o For computing the difference between the sets, use the expression “ #1 #2 – “  

and select Evaluate. A third trace (blue) showing the difference of the two original ones 
should now appear on the main Plotter window (Figure 24).  

o For computing the average of the sets, use expression “ #1 #2 + 2 / “ (note blanks 
between operators and operands).   

 

Figure 24: Xplotter Set operations. 
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6.3 Launch SourceModelling (Xfit) and load data 

• Select Applications -> Neuromag toolbox -> SourceModelling (Figure 25). 
• Select File -> Open (Alt-o) and select jn_sef_01_raw_sss_ave.fif. 
• From Available data, select *>SEF right>average. 

 

Figure 25: Starting Xfit and loading data. 

 

6.4 Load single sphere head model 

• The best-fitting sphere model was computed on the subject’s MRI in section 4.3.  
• Add the resulting origin coordinates to the Sphere model parameters in the Conductor model 

parameter window in Xfit (Figure 26) using either method: 
o Use the center mouse button to click and hold over the sphere origin dialog in Mrilab. 

Drag and release the mouse on the Sphere model parameters dialog in Xfit (the blue 
arrow in Figure 26).  

o Type the sphere origin coordinates manually into the dialog. 

 

Figure 26: Drag and drop the optimal sphere origin from Mrilab. Make sure that you have 
selected the head coordinates in the Xfit conductor model parameters dialog. 
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7 Prepare events for epilepsy source localization 

 Figure 27: Steps for preparing events for epilepsy source localization. 

7.1 Load Graph setup epilepsy-3.3 

• Open Applications -> Neuromag -> Graph (Figure 28). The Graph display shows text ‘Nothing 
connected’. 

 

Figure 28: Graph launching and initial display. 

• Open File -> Load Settings and select setup file  
~HOME/lisp/setup/local/epilepsy-3.3.setup. 

• File -> Change directory, select 
/neuro/data/demo/example_epi/190122. 

• File -> Open Diskfile, select file 
sim_spikes_raw_tsss_mc.fif. 
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Figure 29: Graph epilepsy-3.3 setup showing one selection of MEG data, EEG and a match signal 
channel with threshold and ECG. Tear-off menus is also shown. 

• Menu selections Displays->Views, Parameters->Displays and Commands->Search are 
explained in detail in Appendix B: Quick reference for Graph Epilepsy setups (chapter 16). 

• Open Commands -> Search -> Event lists and detach tear-off menus Displays->Views, 
Displays -> MEG selection, and Commands -> Search -> Manual marking by clicking the 
dashed line in the list so that it will remain open and on top of screen (Figure 29). Note that 
all the menus that have the dashed line work the same way. 

• To select a sensor, or group of sensors, left click and drag over display. 
• To select a time point, right-click.  
• To de-select, left click in the grey area to the left display. 
• You can use Views -> Scroll to make a quick visual review of the data. 
• Adjust scales as needed: Select a group of sensors, then select Views -> Bigger or Smaller. 
• Adjust filters as needed: Displays -> Control Panel -> meg-filter, e.g. (band-pass 3 70). 

To include a line noise notch filter, enter (combinef (bandpass 3 70) (notch 60)). 
• You can define the length of displayed data in all windows by editing Views -> Length… 

7.2 Define EEG cap 

• If EEG was recorded with a cap (32/64/128 channels), first define the EEG cap type in 
Parameters -> misc-defaults (Figure 30a).  

• Currently supported choices are: “Headbox”, “TRIUX cap”, “Vectorview cap”, and “Easycap” 
(see section 16.1 for details). 

• Note that in the demo file sim_spikes_raw_tsss_mc.fif, the proper selection is 
“Headbox”. 

• Change the EEG montage using the Displays -> Derivations.  
• The standard choices include longitudinal, transverse and referential bipolar montages, as well 

as all EEG channels referenced to Cz in groups of 32 channels (Figure 30b).  
• Tailored derivations and site-specific preferences can be defined in the configuration file 

/neuro/lisp/local/graph-2.94/config/eeg-derivations2.lsp  
(see section 16.2 for details). 

ECG 

“Match” signal 

MEG 

EEG 
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a)  b)    

Figure 30: a) Set the EEG cap. If it is not set, Displays -> Derivations will show an error message.  
b) Default EEG derivation choices. 

7.3 Mark events 

• Review the data to find an event. 
• Right-click the peak of the event. Note that there is no automatic alignment of the event, so 

you need to select the “same” time point from the events (typically peak). 
• Assign the event type by selecting Event-A/B/C from the manual marking menu or use the 

shortcuts F10, F11 and F12, respectively (check that NumLock is turned off). 
• Manual events are added to the Event lists left-hand panel (All events). 
• Review the events in the list and adjust event type if needed: Select the event in the list then 

select Event-A/B/C from the manual marking menu. 
o Jump to the existing events by double clicking it in the list. 
o Event lists can be saved from Event list window: File -> Save all events/Save filtered 

events. 
o See also section 14.5 for the event lists. 

7.4 Launch Xfit and transfer event 

• Open Xfit from Graph: Displays -> xfit -> Start xfit. 
• Double-click a filtered event from the Event lists dialog. An error dialog will appear if the 

conductor model parameters have not been entered. 
• Click on Xfit to reveal Conductor model parameter window. See below. 
• Alternatively, select a region and send to Xfit: Display -> xfit -> transfer selection. 

7.5 Load single sphere model 

• The best-fitting sphere model was computed on the subject’s MRI in section 4.3.  
• Add the resulting origin coordinates to the Sphere model parameters in the Conductor model 

parameter window in Xfit (Figure 26) using either method: 
o Use the center mouse button to click and hold over the sphere origin dialog in Mrilab. 

Drag and release the mouse on the Sphere model parameters dialog in Xfit (the blue 
arrow in Figure 26).  

o Type the sphere origin coordinates manually into the dialog. 
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8 Perform source modelling  
The following sections guide the user through a typical workflow for single dipole fitting using a single 
sphere model. The first two sections show how to Launch SourceModelling and Load Single Sphere 
Model. When performing source modelling on epileptic spikes, this software should be launched 
directly from Graph setup (see Section 7.4). 

 

 Figure 31: Workflow steps for source modelling with a single sphere model. 

8.1 Review data on spatial displays 

• Xfit user interface is shown in Figure 32; see the Source Modelling Software User’s Guide for 
the details of the controls and display areas. 

• In the upper left corner Signal waveform window, select a time point by mouse left-click. 
• Enable Show amp. to display the blue RMS amplitude curve (encircled in Figure 32). 
• Review the Spatial distributions displayed on the right: nine individually controllable displays 

of spatial distributions, such as contours, model contours, difference contours, gradient 
contours, EEG contours, arrows, model arrows, or MNE arrows.  

• Select desired Overlay options (in the bottom part of the display): review the MEG sensor 
outlines, dipoles projected onto the isocontour surface, standard head surface, BEM meshes, 
and isotrak points. 

• Review the spatial displays at different time points, also using the animation controls (Movie: 
forward and backward arrows) on the lower right corner of the main display. 
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Figure 32. Xfit user interface main display shows nine views of MEG contours, here overlaid with 
the standard head surface and isotrak points. 

8.2 Review data on sensor displays 
Select View -> Full view (Figure 33).  

 

Figure 33: Xfit full view display. Channels on the left hemisphere have been selected, while the 
channels inside brackets are ignored in dipole fitting. 
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8.3 Fit a single dipole 

• Pick a sample waveform: in the Full view of channels, left click one of the selected channels, 
preferably the one with the most prominent signal. 

• View the Signal waveform in the upper-left corner of the main window (Figure 34).  

 

Figure 34: Xfit single dipole fitting at the 31 ms peak of somatosensory evoked responses, after 
selecting the channels on the left hemisphere. 

• Select a time point: using corresponding field patterns, select a time point where the contour 
maps show a symmetrical dipolar field pattern containing as many contour lines as possible.  

• Fit the dipole by pressing the Fit button.  
• A Dipole fitting window will appear containing all the location and statistical parameters of 

your dipole (Figure 34).  
• The upper part of the Dipole fitting window contains a list of dipoles. Each row represents 

one dipole. The following parameters of the dipole are given, from left to right: 
(1) Time point or time range where the dipole was fitted. 
(2) Cartesian x-, y- and z coordinate of the source estimate. 
(3) Distance of the dipole from the sphere model origin. 
(4) The dipole moment [nAm]. 
(5) x, y and z-components of the dipole moment vector. 
(6) Goodness of fit (g-value), or how large fraction of the variance of the measured data is 

accounted for by the dipole. 
(7) Confidence volume within which the dipole should lie with 95% certainty (sphere model). 
(8) Khi-square (c2) statistics and the number of degrees of freedom of the sphere model.  
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8.4 Adjust fitting parameters 

When fitting a dipole, it may be necessary to adjust some parameters to obtain the best fit. The 
example given are a good starting point. Iterative adjustments may be necessary depending on the 
data. 

 Channel selection 

• Select channel subsets for dipole fitting – a set of channels that contain signals which appear 
to be generated by a single current source. In practice, this means a sub-set of one third to 
one half of the number of channels (~100-150). 
o Select channels with similar waveforms: right-click and drag a rectangle over the 

channels, ignored channels will appear in brackets. 
o To refine the selection, continue to press Shift and select individual channels on and off 

with the right-click. 
o To un-select channels, right-click anywhere in the white space 

 Noise level estimation 

• Select File -> Preferences -> Fitting… (F10) in the main display, or File -> Preferences in the 
Dipole fitting dialog. For the demo dataset, select Compute from baseline.   
o Constant value is the default setting, corresponding to normal evoked response 

measurements where ~100 epochs are averaged, and signal bandwidth is 100 Hz. The 
default values are 5 fT/cm for gradiometers and 20 fT for magnetometers. For single, 
unaveraged spike events, the recommended values are 50 fT/cm for gradiometers and 
200 fT for magnetometers. 

o Compute from baseline (recommended) means that the channel-specific noise levels are 
estimated from the baseline. This setting is strongly recommended if the responses have 
poor signal to noise ratio, such as non-averaged single epochs. 

 

Note: The noise level values affect somewhat the accuracy of the dipole fits through weighting of 
magnetometer and gradiometer channels in dipole fitting (Source Modelling Software User’s Guide 
section 9.1.2) and they determine the confidence limits (Source Modelling Software User’s Guide 
section 9.1.6). 

Care must be taken to use proper noise estimates. The default constant values have been set for 
normal evoked response measurements where roughly 100 epochs are averaged, and signal 
bandwidth is 100 Hz. If these settings are used with unaveraged epochs, the confidence limits will 
be grossly underestimated (the estimated confidence limits are narrower than the true standard 
deviation of the dipole parameters). The expected sensor noise level in the average can be 
obtained from the RMS noise density of the sensor by multiplying it with the square root of the 
ratio of bandwidth and number of averages. Even when fixed noise levels based on the known 
system noise are set correctly, the brain background activity can produce “noise” that is clearly 
higher than the estimate, causing again the confidence limits to be underestimated. 

Using the baseline standard deviation as the noise estimate is independent of averaging and 
acquisition parameters and gives generally a bit more accurate dipole-estimate. It is the 
recommended setting for general cases. However, in some special situations (for example, if the 
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baseline is not a true baseline, but contains also the signal itself) properly set fixed values can 
provide better results. 

The noise is also assumed to be independent on each channel, and in presence of correlated noise, 
the variance in the dipole estimates may be somewhat higher or lower than what the confidence 
limits based on the noise levels calculated from the baselines suggest. For example, with data that 
has been filtered with MaxFilter, the software has tendency to somewhat underestimate the 
confidence limits. 

 Baseline 

• Select Process-> Baselines… (Alt-p + b) in the main display, check Use baseline and enter 
baseline window [-100, -5] ms. The average level of the signal during baseline is now set as 
the zero level of the signal (DC offset). This baseline is also used when baseline noise 
modelling is selected. 

 Filtering  

• Select Process -> Filter… (Alt-p + f) in the main display, select Lowpass and enter 40Hz and 
width of 5Hz. 

8.5 Evaluate dipoles  

 Compare fit statistics to acceptance criteria 

• Test the residual for modeling error by inspecting the goodness of fit, confidence volume and 
c2 (khi-square) values.  

• The “reduced khi-square” value is obtained by dividing the reported c2 with the number of 
degrees of freedom (nfree) which equals to the number of used channels minus the number 
of dipole parameters. The background noise must be estimated from the baseline or 
constant noise values of unaveraged epochs must be used (e.g. 50 fT/cm for gradiometers 
and 200 fT for magnetometers). 

 

 The following steps are used to evaluate if the result is a “good model”. 
• Check the statistical parameters: 

o Goodness of fit > 80 %. 
o Confidence volume < 1000 mm3. 
o Reduced khi-square: c2/nfree < 2. 
o Dipole amplitude is between 100 nAm and 500 nAm. 

• If the parameters are acceptable, transfer the dipole to MRI and check that  
o The fitted location is at, or close to, the cortex. 
o The orientation is roughly perpendicular to the gray-white matter boundary. 
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 Review how well the dipole model explains the data 

XFit contains powerful features that enable you to compare visually the predictions of the dipole model 
with measured data. This is often the best way to get an idea about the real goodness of the dipole fit. 

• It is possible to review the source waveform and the residuals.  
o Select File -> Preferences -> Fitting… (F10) in the Dipole fitting dialog 
o Select Show predicted waveforms, select Done. 
o In the Dipole fitting window, activate a dipole display by clicking the “1” box, see Figure 

35 (A) 
o Center-click on the dipole of interest from the list of dipoles and drag to the activated 

display row. 
o In the Time (amp) row, click Full scale, see Figure 35 (B). The source waveform and 

residuals are displayed in the main window (Figure 35 (C)) and overlaid in the Full View. 

 

Figure 35: Plot source waveform and residuals for a dipole estimation. 

• Review the Full view window that contains the original responses with the predicted signals 
superimposed (Figure 36).  

• Examine how well your dipole model predicts the data: zoom in/out by using Shift + left 
drag/click over an area. Go to the main window. If you have selected a time point close to 
the signal peak, you should see your dipole as a green arrow on top of the field patterns. 

A 

B 

C 
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Figure 36: Xfit measured and predicted MEG channel waveforms. 

 Overlay fitted dipoles on co-registered MRI with Mrilab 

Observe the location of the fitted dipole to be close to the expected location (functional mapping), 
close to the cortex, and the orientation is roughly perpendicular to the gray-white matter boundary 

• Launch Applications -> Neuromag -> MEG-MRI integration 
• File -> Open (Alt+o), then select MRI with the correct anatomical landmarks and co-

registration: /neuro/mri/example_case/sets/*_01-<username-date>.fif  
• Click Apply. 
• Select the dipoles from the list in the Dipole fitting window, right-click -> MRI (Figure 37). 
• Set File -> Preferences -> Interface style (Alt-f + p + i) to ‘Standard’. 
• Select Windows - > Object tree, double-click on an object in the object tree to select a new 

style for the dipoles (Figure 38). 
• NOTE: when you send a list of dipoles from Xfit, all dipoles will be treated as a single object 

and will have the same appearance. Send the dipoles one by one if you wish to handle them 
as separate objects in Mrilab. 
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Figure 37: Importing the two-dipole fit locations to Mrilab. 

 

 

Figure 38: Mrilab object tree and changing the dipole appearance. 
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8.6 Save dipole fits 

• In Xfit Dipole fitting window, select dipoles for saving, use Selection -> Save and save the 
dipoles in a binary *.bdip file, see Figure below.  

• To save only those dipoles that were sent to the MRI, from Mrilab select File -> Export -> 
Dipoles (Alt-f + e +d) and save to an ASCII *.dip file.  

• Saved binary (*.bdip) and ASCII (*.dip) files can be loaded back into Mrilab by selecting File -> 
Import -> Dipoles (Alt-f + i + d) (Figure 39). 

 

 

Figure 39: Selected dipoles can be saved to a binary or ASCII file. 
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9 Prepare DICOM export and clinical report 

 Figure 40: Workflow steps for preparing DICOM export and clinical report. 

9.1 Print hardcopies 

• The easiest way to create hardcopies is to press the Print screen button or to use a suitable 
Screenshot capture application in Linux. Save the output (the whole display, window under 
cursor, or selected region) as a png bitmap file. 

• Alternatively, right-click on top of the display and choose Print command from the popup 
menu to send the captured image to printer, vector-graphic Illustrator output file, or a TIFF 
output file.  

• Make printouts of (1) your dipole list, (2) source waveform and g-value graphs, (3) field 
patterns and dipoles on the helmet array on some chosen time point, and (4) Full view window 
or some part of it containing the original and predicted responses. Note that you can print all 
nine field pattern figures on one paper if you right-click on the bar below them, containing the 
text "View", "Contours", "Def. camera" and so on. In some cases, you may add your own notes 
to the printouts — in this case, an annotation window will appear before printing. 

• Note: Linux operating systems generally provide feasible screenshot functionality with Print 
screen or a Screen capture application. If there is need to adjust the image resolution or other 
properties, you may need to search and apply a special Linux tool for modifying the picture, 
adjusting the borders, depth, color and a lot more while capturing screen of a particular 
application or a whole window. 

9.2 Export graphics for reporting with Cliplab 

• Launch Applications -> Neuromag -> Graphics Clipboard. 
• Select the 2-by-2 layout (Figure 41). The dialog can remain open side by side with the data 

analysis program windows. 
• Select a figure with the middle mouse button and drag-and-drop on the clipboard. Use this 

for any figure window from MaxFilter, Graph, Xplotter, Mrilab, and Xfit programs.  
• Select Layout -> Add Page to add pages to the report. 
• Export the graphics, File->Export or obtain a hardcopy, File->Print. 
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Figure 41: Graphics clipboard. 

9.3 Export dipole fit results to DICOM using Mrilab 
The dipole fitting results can be exported in DICOM format, and viewed in external DICOM compatible 
systems, such as in an intraoperative neuronavigator. The DICOM export is performed with Mrilab. 

• Select File -> Print. A dialog pops up (Figure 42). 
• Select Destination: File. 
• Select Target format: DICOM, it will automatically set also Source: Viewer, Full view(s); 

Format: Gray-scale. 
• Select Image & LineArt to export also the dipoles. 
• Note: In order to hide disturbing object such as the crosshair 

cursor, labels and dipole arrow from the exported images,  
o Right-click on the upper left viewer, check that you have 

Modes -> Slice, and select Mode Prefs. Uncheck all three 
options to hide the crosshair. 

o Select Objects -> Object Preferences and set Dipole vectors: 
None. Note that also the selected Slice thickness affects how 
the dipoles are shown in the exported DICOM slices.    

 
• Create a new directory where you want to export the DICOM 

files, e.g. /neuro/data/demo/mri/dicom_export. 
• Select Destination: File, browse to the freshly created export 

directory. 
• Set output file name, e.g. 

/neuro/data/demo/mri/dicom_export/example_case. 
• Press Save, another dialog pops up for export options (Figure 43). 
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Figure 42. Mrilab printing dialog, DICOM export. 

 

Figure 43. Options for DICOM export. 

• Select Series to export all DICOM slices. You can also specify the separation between 
calculated output slices. 

• By default, the dipoles will be "burned" to the MRI, i.e. high intensity pixels in the form of a 
cross will be added to the MR image in the dipole location. Only the location of the dipole is 
encoded in the output, not the orientation of the dipole.  

• Optionally, you can select Use DICOM overlay planes to exports dipoles in DICOM overlay 
planes. NOTE: Please make sure that the external system viewing the DICOM exports can 
support overlays before using this export option. 

9.4 Prepare clinical report 
Guidelines for preparing clinical reports can be found in ACMEGS Clinical Practice Guideline 3: MEG-
EEG Reporting. It is necessary that clinical staff receive specialized training from a clinical MEG expert 
before commencing with MEG data collection and analysis. Formalized training should include 
additional information about clinical reporting. 
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10 Next steps: Topics for advanced SourceModelling 

10.1 Estimate spike onset activity – sequential single dipole fits 
If the dipole model result is acceptable, the analysis can proceed to estimate the spike onset activity. 

• Select Signal waveform window in the upper left corner of the main display, right-click above 
the displayed curve and choose Sequential single dipole fit from the popup menu.  

• Press and hold Shift, then select a time range by clicking and dragging with the left mouse 
button. The background color in the selected area will turn gray. 

• In Sequential fitting window, confirm appropriate values and select Fit.  
• In Dipole fitting window, select the whole list by left-dragging, then right-click to make a 

popup menu appear.  
• Select Filter command from the popup menu. Select the g > (%) checkbox and type in the 

limit value 95. Select Ok.  
• Those dipoles whose g > 95 % should appear in the selection window below the list. If none 

appeared, the criteria were too strict, and you must try another value. 
• Find the earliest time point at the onset that fulfills the acceptance criteria above. 
• Check that the dipoles form a cluster, highlight the filtered dipoles, right-click, Print -> MRI. 
• Estimate the distance peak fit and earliest time point fitted for assessing propagation of the 

source location. 

10.2 Fit a two-dipole model 
You can apply the preceding principles to expand the model to a set of multiple concurrent dipoles. 
This can be used when you suspect there are more than one simultaneous active sources.  

• Load file /neuro/data/demo/example_case/190613/jn_aef_eo_ave.fif and select 
*>AEF right>average dataset. 

• Enter the sphere origin coordinates defined earlier for the demo subject. 
• Adjust the baseline, Process -> Baselines… (Alt-p + b), Use baseline [-100,-5] ms. 
• Adjust the filter, Process -> Filters… (Alt-p + f), Lowpass 40Hz, width 5Hz. 
• Open Full view (F5), select a set of channels over the right hemisphere and fit a dipole.  
• Activate Row 1 in the multidipole dialog (Figure 44, bottom window of the Dipole fitting 

window). 
• Select the dipole from the list with the center mouse button and drag it into Row 1. 
• Select another set of enabled channels over the left hemisphere and fit a dipole.  
• Activate Row 2 and add the second dipole (Figure 44).  
• Right click on the Full view window to activate all channels (no channel sub-sets). 
• Select Full scale on the Time (amp) row in the bottom part of the multidipole dialog. 

Review the Source waveforms: The dipole source waveforms appear on the left frame of the Source 
modelling window, presenting the amplitudes of the dipoles as a function of time (Figure 44). The time 
scale is the same as in the signal waveform graph on top of it. The bottom curve represents the 
goodness of fit and tells you how many percent of your data can be explained with your dipole model. 
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Figure 44: A two-dipole model in Xfit. 

Note that this is a demonstrative example of a two-dipole model where the dipole locations are first 
determined using separate single-dipole models for selected channel groups. The locations are then 
fixed over the amplitude fitting period, and all channels are utilized to determine the time-courses of 
the dipoles. The full multidipole modelling is beyond the scope of this guideline; see the Source 
Modelling Software User’s Guide Chapter 9 for the details.   

In general, beware of interactions in multidipole modelling. If you have multiple dipoles and their 
temporal activation curves show similar timing but with opposite polarities, the dipoles may try to 
explain each other, not real brain signals. Make a multidipole model to explain as much of the data as 
you think is necessary. Pay special attention to the goodness-of-fit of single dipoles, to the absence of 
interactions, and to the similarities of the measured and predicted signals (see the next section). 

10.3 Characterize a dipole using PCA projections 

The dipole fit can also be characterized using a PCA projection.  
• After fitting a dipole, select Process -> Projection… 
• In the Linear projection window select Add -> Selected dipoles (fixed). 
• Then inspect the results, select Use -> Projection, Compliment and Original to determine 

residuals that may have different onset latency from the fitted position. See Signal Processor 
User’s Guide, Chapter 10 for additional information. 
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11 Next steps: Inspect and correct the head position  

11.1 Head position inspection 
If the visual head position inspection (section 4.4) reveals a problem, the following steps provide 
guidance for trouble shooting and correcting the problem. 

The head position in FIFF files is determined by a device->head coordinate transformation. To inspect 
it, apply the terminal window command /neuro/bin/util/show_fiff –vt222 filename.fif. 
For instance the transformation in Figure 14 is: 

222 = transform         device -> head 
      0.999533 0.030220 -0.004530 
     -0.030521 0.994591 -0.099281 
      0.001505 0.099373 0.995049 
     -1.473818 -4.034752 57.537861 (inv. 1.263396 -1.660221 -57.660248) 

The last row after the 3x3 rotation shows where is the device coordinate origin in the head coordinate 
frame. Here -1.47 -4.03 57.54 means that the device coordinate origin is 1.5 mm left, 4.0 mm back and 
57.5 mm up from the head coordinate system origin. If the z-value is large (>70 mm), it usually points 
to a low head position.  

MaxFilter GUI and Xfit dialogs for the origin parameters is also useful (MaxFilter User’s Guide section 
3.2.2 and Source Modelling Software User’s Guide section 5.2). When you type the selected origin in 
the head coordinates, select ’Coordinate system -> device’ to display the origin coordinates in the 
device frame. If the resulting point is >25 mm from (0, 0, 0), the trans-operation in movement 
correction may increase reconstruction noise. 

Head positions estimated from continuous raw data can be viewed in the MaxFilter Graphical User 
Interface, see MaxFilter User’s Guide section 4.5. Note: During data collection, cHPI should be selected 
BEFORE selecting Raw. This ensures the initial position is properly reflected in the display. 

11.2 HPI order verification 

You can verify the detected HPI coil order in the following manner. Open a terminal window and 
navigate to the directory where your datafile is located. Issue the following command: 

/neuro/bin/util/show_fiff -vt247 <filename.fif> 

This shows the detected coil order, for example: 

247 = HPI coil order  5 ints (2 5 4 3 1) 

Note: you need show_fiff version 1.4 or later to display the coil order. Next type the following 
command to see the digitized points: 

/neuro/bin/util/show_fiff -vt213 <filename.fif> | more 

Inspect the first lines which look like the following: 
213 = dig. point  hpi  1 ( -68.2, -24.7, -50.8) 
213 = dig. Point hpi  2 (  69.8, -25.6, -58.4) 
213 = dig. Point hpi  3 (  54.6,  76.0,  28.4) 
213 = dig. Point hpi  4 (  29.6, 102.5,  24.2) 
213 = dig. Point hpi  5 ( -46.8,  87.2,  24.7) 
213 = dig. Point cardinal   1 ( -67.4,   0.0,   0.0) 
213 = dig. Point cardinal   2 (   0.0, 105.4,   0.0) 
213 = dig. Point cardinal   3 (  67.6,   0.0,   0.0) 
213 = dig. Point hpi         1 ( -46.7,  91.7,  43.8) 
213 = dig. Point hpi         2 ( -67.1, -32.2, -1.6) 
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213 = dig. Point hpi         3 (  32.4, 101.1,  43.9) 
213 = dig. Point hpi         4 (  56.0,  78.0,  34.6) 
213 = dig. Point hpi         5 (  68.0, -35.1,  -1.5)   

The first five lines give the fitted coil locations in the device coordinate frame, the next three lines 
show the digitized landmark points, and the following five lines give the digitized coil locations in the 
head coordinate frame. In this example the fitted coil locations follow the colour-coded hardware 
order and match the following regions: 1. Left frontal, 2. Right frontal, 3. Right posterior, 4. Middle 
frontal, 5. Left posterior. By comparing these with the digitized coordinate values, we can judge that 
the first (blue) coil matches with the second digitization, the second (white) coil with the fifth 
digitization, the third (red) with the fourth digitization, the fourth (black) with the third digitization, 
and the fifth (yellow) with the first digitization, thus confirming that the correct coil order 2 5 4 3 1 was 
used and saved in the file.      

11.3 Correct the head position 
If the comparison between the fitted and digitized coil locations results in a different order than it was 
written in the file, the head position can be fitted again with the corrected coil order. Log into the data 
acquisition workstation, open a terminal window and navigate to the directory where your datafile is 
located. If you have digitized the coils in the colour-coded order or defined the correct order as in the 
previous section (for example, 1 2 3 4 5), issue the following command: 

/neuro/dacq/bin/hpifit -file <filename.fif> -swap 12345 

This command writes the new head position in a new file hpi_coils.fif. Copy the new head 
position into the FIFF file using the command    

/neuro/bin/util/copy_trans_fiff -r hpi_coils.fif <filename.fif>  

Inspect the corrected head position as advised above. If the correction still produces an incorrect head 
position, you should report the problem to support@megin.fi and request for further advice. 
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12 Next steps: Optimize MaxFilter Processing 
MaxFilter is easy to apply and the default settings provide good results in most cases. The program has 
a set of parameters which can be adjusted if tuning of the performance is needed. Please see MaxFilter 
User’s Guide chapter 3 for detailed description of the parameters and pay special attention to possible 
warnings associated with changing the parameter values.  

12.1 Selecting the task 
1. Determine if MaxFilter processing is necessary 

• Has IAS been ON during the data recording?  
o YES -> SSS or tSSS required. 
o NO -> SSS or tSSS recommended. 

• Are there considerable interference artifacts on the data? 
o YES -> SSS or tSSS recommended. 

2. Select between SSS and tSSS processing 
• Is there low-amplitude external interference only? 

o YES, external only -> use SSS (tSSS also possible for reducing noise and artifacts).  
• Are there also close-by artifacts or artifacts inside of the sensor helmet, or strong 

external interference?  
o YES, close-by artifacts -> use tSSS.  

3. Set tSSS parameters 
• Buffer length usually 10 s; sometimes longer buffer (e.g. 30 s) may be more effective. 
• Correlation limit 0.98; sometimes reduction (e.g. to 0.9) is needed for better interference 

suppressions.  
4. Select the Head position task 

• Has cHPI been ON during the data recording?  
o YES, cHPI on -> use head movement compensation.  
o NO -> Not possible to use head movement compensation. 

• When head movement compensation is used, does the initial head position represent 
well the overall head position in the data file? 

o YES -> head position transformation to the initial head position.  
o NO -> head position transformation to the average head position. 

• When no head movement compensation is used, will there be sensor level comparison of 
different data sets? 

o YES –> use head position transformation to align the data sets to same position. 
o NO –> no head position transformation needed. 

5. Select movement compensation 
• Movement compensation usually requires combined tSSS processing. 
• When processing raw data with cHPI signals, the recommended settings are  

o Use initial head position.  
o Movement correction with tSSS.  
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12.2 General recommendations for successful MaxFilter processing 

• Generally, (t)SSS and movement compensation give robust performance for suppressing the 
interference and disturbances cause by head movements when the head is placed well inside 
the helmet. Then the choice of the origin does not play a significant role, and the 
recommendation to use the origin according to a sphere fitted to isotrak points or MRI data 
is aligned with the spherical head model definition in source modelling (see section 4.3). 

• The head should be well positioned inside the helmet. This can be inspected during an HPI 
measurement by checking the measurement Head origin (see the Data Acquisition Guidelines 
Chapter 7). If the absolute value of the z-value is > 70 mm, the subject head may be too low in 
the helmet. See also Chapter 11. 

• Transforming the head position more than 25 mm shows increased noise on some MEG 
channels. It you suspect the subject has move a lot during the recording, it may be helpful to 
take an HPI fit at the end and compare the positions. This would require that you take note of 
the position at the beginning of the measurement as well. 

• MaxFilter checks for quality HPI fit. If poor fits are present, then movement compensation can 
create noise in the recording. If you suspect poor fits, it is helpful to take an HPI fit at the end 
of the recording for quality control. HPI can be measured and saved with a very brief recording. 

• Whenever possible, the patient sphere origin should be use instead of the default position for 
all MaxFilter processing. 
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13 Next steps: Topics for using Graph standard setups 
This section complements the Graph manuals and contains detailed instructions for using two general 
Graph setups: i) Basic setup for simple data viewing, and ii) Comparison setup for opening and viewing 
data from two datafiles. 

The basic operations of Graph are described in detail in the Signal Processor User’s Guide section 1.2. 
The basic setup is available when the Data Analysis software has been installed. The reader is 
suggested to consult the Signal Processor User’s Guide (Part 2) for more detailed explanation of Graph 
setups and widgets. 

13.1 Review data with Graph basic.setup 
After applying pre-processing to a raw dataset, it is recommended to visually review the results to 
confirm proper automatic detection and correction of interference artifacts. 

• Open Applications -> Neuromag -> Graph (Figure 45). The Graph display shows text ‘Nothing 
connected’. 

 

Figure 45: Graph launching and initial display. 

• Select File -> Load settings, select ~HOME/lisp/setup/examples/basic.setup. 
• Select File -> Open Diskfile and load a MaxFilter -processed raw datafile, e.g. *_raw_sss.fif. 

(Note: this review needs to be repeated for all the pre-processed files). 
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a)  b)  
Figure 46: a) Select the basic.setup file. b) Select a FIFF datafile. 

 Review the Graph display  

• The main display shows now a set of MEG channels (Figure 47). 
• Adjust the channels: Displays -> Selection (Alt-d + m), select a channel group. To keep the 

selection menu open, select the dashed line as the top of the menu (Selection Tear-off).  
• Change the display time: adjust using the slider at the bottom of the display, or by typing 

values in the fields Start & length.  
• Adjust the amplitude scales using the Scale and Offset controls in the upper right corner of 

the dialog. 

    
Figure 47: Graph display when the basic.setup and a FIFF file have been loaded. The channel 
selection menu is opened from Displays -> Selection. The control panel is shown on the right. 

• Select Displays -> Control panel to view the widgets in this setup. Double-click on a widget to 
see the resources (see the Signal Processor User’s Guide sections 2.2-2.4 for details). 

• If the datafile has EEG channels, you can select them instead of MEG: right click on the 
widget eeg in the control panel, keep the right mouse button pressed, drag a connection 
from widget eeg to widget display, and adjust the amplitude scale. 
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 Adjust the time scales  

• Note: this section does not apply to TRIUXTM neo data. FIFF files recorded with Data 
Acquisition Software release 6.0.5 (or later) do not contain initial data skip tags.  

• For older acquisitions, using compress-skips allows for all initial data skip tags between 
pressing the GO button in data acquistion and starting saving raw data are neglected. Thus, 
the raw data time scale in the display usually starts from 0.  

• Select File -> Open Diskfile, select the button resources in the file selection dialog (Figure 
46b). By default, compress-skips is active (Figure 48).  

• However, the initial skips are meaningful when the data viewing time scale must be the same 
as in MaxFilter (see MaxFilter User’s Guide section 2.6 for details of the raw data time scale). 
In such cases you need to deactivate the button compress-skips. 

 

Figure 48: Compress skips. 

 Adjust the filtering 

• Select Displays -> Control panel (Alt-d + c) and double-click on widget meg-filter (or eeg-
filter) to adjust the filter settings. The details of the filtering are presented in the Signal 
Processor User’s Guide section 4.2. In brief, you can set high-pass, low-pass, or band-pass by 
typing in the text field next to pass-band (Figure 49).  

• Enter (band-pass 1 100) in the pass-band field. 

 

Figure 49: Adjust the filtering parameters. 

• Available options are  
o (high-pass <corner> [<transition-width>]) 
o (low-pass <corner> [<transition-width>]) 
o (band-pass <corner1> <corner2> [<transition1>] [<transition2>]) 

o nil (= no filter) 
• In addition, button remove-dc affects like a high-pass filter which has the lowest possible 

corner frequency. If pass-band is nil, remove-dc has no effect. 
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13.2 Compare two files with Graph compare.setup 

Sometimes it becomes necessary to compare MEG data in two files visually, either by looking the same 
data before and after MaxFilter -processing or by viewing two comparable data sets. Therefore, the 
compare.setup is useful because it provides the controls and connected displays to open and view two 
datafiles in synchronized manner. 

• Select File -> Load settings, select ~HOME/lisp/setup/local/compare.setup.  
• The Graph display shows two synchronized windows (Figure 50). The control panel has 

separate controls for both windows (Figure 51). 

 
Figure 50: Graph displays in compare.setup. The windows are connected so that changing the 
channel selection or time point on one display automatically adjusts also the second one. 

 
Figure 51 : The control panel for compare.setup. 

• A typical comparison is between original and pre-processed data, such as the raw data 
before and after MaxFilter processing. 

• The selections in the Graph menus, e.g. File and Displays affect the first source file. 
• Open the first source file from File -> Open Diskfile, select a raw file (*_raw.fif). 
• Open the second source file by double-clicking widget file2 and select a MaxFilter -processed 

file (*_raw_tsss_mc.fif). 
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• Channel selections Displays -> Selection affects both windows.  
• The time scale is the same for both files whether compress-skips is active or not. 
• Ensure the amplitude and time scales and filter settings are similar in both windows. 
• Note that when changing the channel selection from gradiometers to magnetometers (and 

vice versa), it is necessary to adjust the amplitude scales in both windows. 
• If the source files originate from different data sources, their time scales may be different. 

Activate compress-skips in the widgets file and file2 on the control panel, if needed. 

13.3 Add or remove SSP vectors in a Graph display 

When MaxFilter is not applied, the spatial SSP vectors saved in the recorded file can be used for 
interference suppression. 

• To apply Signal Space Projection (SSP), add an SSP widget by typing on the command line 
below the menus in the Graph display (Figure 52): 
(require “ssp“)  

 

Figure 52: Add the ssp widget to a Graph setup. 

• Select Displays -> Control panel (Alt-d + c) and link widget ssp (Figure 53): 
o Drag widget ssp between widget meg and widget pick. 
o Select widget meg, right-click and connect to widget ssp. 
o Select widget ssp, right-click and connect to widget pick. 

• Select Commands->SSP dialog… to open controls for loading and activating SSP vectors. 
• Select File->Load to select the raw file from which to load the SSP vectors. 
• Select vectors on the left panel of the SSP vectors dialog and click the arrow (->) button to 

make them active (Figure 54). The vectors can be turned on and off using the buttons On and 
Off. The label on the right column then indicates SSP vectors ON or SSP vectors OFF. 

 

Figure 53: Link widget ssp in the control panel between ‘meg’ and ‘pick’. 
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Figure 54: Select Commands ->SSP dialog to load and activate the SSP vectors. 

13.4 Connect Xfit to Graph setup 

Working with the plotting and source modelling programs (Xplotter and Xfit) can be done by selecting 
a time window of raw data and making an evoked file (File -> Make evoked file).  

It is, however, more convenient to apply special lisp routines “xplotter.lsp” and “xfit.lsp” which makes 
direct data transfer from Graph to Xplotter and Xfit. See the Signal Processor Reference manual for 
detailed description of the xfit and xplotter items. 

• If Xfit and Xplotter modules are not included in your setup (i.e. not listed in the Displays 
menu), type on the command line: (require “xfit“) 
This will add item “xfit…” in the Displays menu.  

• Select Displays- > xfit -> Start xfit.  
• Select Parameters -> misc-defaults to change the default-data-source which defines the 

channels for the data transfer.  
• Double-click the data source (e.g. widget meg) to edit the names field and specify the 

channel selection. For example, selection “MEG *” sends the data on all MEG channels.  
If the file has EEG data and you wish to see them in Xfit, type a second line “EEG *”. 

• Use the right mouse button on the Graph waveform display to select a short time interval.  
• Select Displays- > xfit -> Transfer selection to send the selection from Graph to Xfit (an 

example is displayed in Figure 58 below). 

13.5 Connect Xplotter to Graph setup 

• Type on the command line: (require “xplotter“)  
This will add items “xplotter…” in the Displays menu.  

• Select Displays- > xplotter -> Start xplotter.  
• Use the right mouse button on the Graph waveform display to select a short time interval.  
• Select Displays- > xplotter -> Show selection to send the selection from Graph to Xplotter. 
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13.6 Adjust parameters in a Graph display  

• Select the Resources button on the right side of the main display to access the parameters 
controlling the display appearance (Figure 55).  

 

Figure 55: Graph display resources. 

• Edit the values to change the appearance of the display (see the Signal Processor User’s 
Guide section 2.4 on page 40 for detailed description of the display widget ‘Plotter’ resource 
parameters). 

• Enter snow in the baseline-color field to change the color of the markers on the display. 
• Available colors are listed in text file /usr/share/X11/rgb.txt. 

13.7 Compute instantaneous spectra using Graph spectra.setup 
Calculation of frequency spectra is described in the Signal Processor User’s Guide section 4.4. Here we 
show two setups for evaluating and displaying frequency spectra from a selected piece of the raw data 
or by averaging the spectra over longer time intervals. 

• Select File -> Load settings, select ~HOME/lisp/setup/local/spectra.setup. 
• Adjust the two Graph displays to fit on the screen (Figure 56).  
• Select File -> Open Diskfile and select a raw FIFF file (*_spont_EC_02_raw_sss.fif). 
• Select Displays -> Selection (Alt-s + m) to pick the left-occipital MEG channels to 

show in both windows. 
• Select Displays -> Control panel (Alt-d + c) and double click widget meg-filter.  

Set pass-band field to (low-pass 40). 
• Change the display time Start & length to change the time in the top window and the 

frequency spectra results in the bottom window. 
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Figure 56: Graph displays of spectra.setup. The upper window shows the raw data signals on 
selected MEG channels, and the lower window displays their frequency spectra computed from 
the beginning of the time scale in the upper window. 

• Select Displays -> Control panel (Alt-d + c) to change the FFT length and averaging step: 
o Double-click widget spec and adjust fft-size and fft-step if needed  

(fft-size = 4096, fft-step = 2048 in Figure 57a).  
o Double-click widget win to set Start and End. Note that the window length (defined by 

start and end) must be longer than analyze-time value  
(Start = 0, End = 4.1 in Figure 57b).  

o Click Apply.  

a)  b)  
Figure 57: Changing a) the FFT and b) the window parameters for evaluating the spectra. 
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13.8 Practice example: alpha waves 

In this example, both instantaneous spectra in Graph and View -> Full view display in Xfit show clear 
alpha oscillations. The timepoint selection at one of the peaks displays a bipolar field pattern in the 
left occipital region. 

• Review the spectra in the lower window of Figure 56. Set Start = 0 and length = 40. 
Notice the increase in 8-10 Hz alpha power.  

• Connect to Xfit by typing the command (require “xfit”) in the command window 
(see View spatial distributions, section 5.1.5). 

• Scan through the data and select a time window of recording containing alpha waves.  
• Select Displays -> xfit -> Transfer selection (Figure 58).  
• Xfit will show the origin selection dialog. If you don’t have the origin fitted to anatomy in 

Mrilab, you can always use the default origin 0,0,40. 
Note: make sure to select the Head coordinates (cf. Figure 26). 

• Review the spatial displays. In this example, both instantaneous spectra in Graph and View -> 
Full view display in Xfit show clear alpha oscillations (Figure 59). The timepoint selection at 
one of the peaks displays a bipolar field pattern in the left occipital region. 

 

Figure 58: Sending data from Graph to Xfit. 
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Figure 59: Xfit displays of alpha waves. 

13.9 Compute averaged spectra using Graph ave_spectra.setup 

• Select File -> Load settings, select ~HOME/lisp/setup/local/ave_spectra.setup. 
• Adjust the two Graph displays to fit on the screen (Figure 60). An Xplotter window is also 

opened for displaying a topographical view of the averaged spectra (Figure 61). 
• Select File -> Open Diskfile and select a raw FIFF file (*_raw_tsss_mc.fif). 
• Select Displays -> Selection to pick the left-occipital MEG channels to show in both windows. 
• Change the display time Start & length to change the time in the top window and the 

frequency spectra results in the bottom window. 
• To display average spectra, type the following lisp-command on the command line below the 

menus and press enter:  
 (average <start> <end>)  

• The start and end times are given in seconds and must be consistent with the earliest and 
latest time in the file. 

• You can use the Xplotter controls in the Process and View menus to change the amplitude 
and time scales and channel layouts, e.g.  
o Time (ms): 0.0 … 100000 to set the frequency from 0 to 100 Hz. 
o MEG (fT/cm): 0 … 20.0 to set the amplitude range (the spectra have only positive 

values). 
o Axial mult.: 4.0 to set the relative vertical scale between magnetometer and 

gradiometer channels. 
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Figure 60: Graph displays in ave_spectra.setup. The upper window shows the raw data signals on 
selected MEG channels. The lower window displays superposed frequency spectra from all left 
occipital channels averaged between 140 and 150 seconds. 

 

Figure 61: Xplotter display shows the updated frequency spectra during and after averaging.  

• Select Displays -> Control panel (Alt-d + c) to adjust the parameters and views (Figure 62).  
• To display averaged gradiometer spectra instead of magnetometers, connect the selector 

widget grads to the display widget averages, and adjust the amplitude scale in the display. 
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Figure 62: Control panel in ave_spectra.setup. 

• Double-click on the prism widget spectra for adjusting the FFT parameters. The details are 
explained in the Signal Processor User’s Guide section 4.4. 

• To save the averaged spectra, type the following lisp-command on the command line below 
the menus:  

(save-average)  
• It opens a file selection dialog for setting the output directory and filename.  
• Optionally, enter the output file directly by typing the path and filename after save-average. 

For example, the following command will save the averaged spectra in an evoked-format file 
amp_spectra.fif under /neuro/data/demo/example_case/180613: 

(save-average “/neuro/data/demo/example_case/190613/amp_spectra.fif”)  

• Saved spectra can be opened and overlaid in Xplotter, like in Figure 61. 
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14 Next steps: Topics for using Graph epilepsy setups 

14.1 Overview of Graph setup epilepsy-2.3 
Both Graph setups presented in this guideline (epilepsy-2.3 and epilepsy-3.3) provide the same 
functionality, but with difference interfaces. The spike search in epilepsy-2.3 displays only the 
gradiometers, while epilepsy-3.3 (see Section 7.1) shows both gradiometers and magnetometers. Both 
setups use all channels for source modelling. 

• Open File -> Load Settings and select setup file  
~HOME/lisp/setup/local/epilepsy-2.3.setup. 

• File -> Open Diskfile, select file sim_spikes_raw_sss.fif. 
• The epilepsy spike search setup is shown in Figure 63.  

 

Figure 63: Graph epilepsy 2.3 setup and tear-off menus. 

o MEG gradiometer channels are superimposed and grouped into eight groups shown on 
the left. 

o Selected groups of channels trace by trace are shown in the top two displays on the right. 
o EOG, ECG, and EEG signals are show in the third panel down on the right. 
o A processed “match” signal used in the spike search (see Appendix B: Quick reference for 

Graph Epilepsy setups, 16.6) is shown in the bottom right display. In addition, a threshold 
is displayed that is used for automatized spike event search. 

o The scroll bar on the bottom of the left side is used to move the view to different time 
ranges.  

o Menu selections Displays->Views, Parameters->Displays and Commands->Search are 
explained in detail in Appendix B: Quick reference for Graph Epilepsy setups (chapter 16). 
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o Detach tear-off menus Displays->Views and Commands->Search by clicking the dashed 
line in the list so that it will remain open and on top of screen (Figure 63). Note that all 
the menus that have the dashed line work the same way. 

o Select Displays-> Views -> View temporal, parietal, frontal, or occipital to change the 
right column views of Figure 63. 

14.2 Define bad channels and threshold for artifact rejection 

• Examine the MEG and EEG channels on the displays to find if there are very noisy or jumping 
channels. 

• Select the bad channel(s). Select Displays -> Views -> Remove bad. Repeat with all groups 
until all bad channels are removed. 

• Note: files processed properly with MaxFilter (such as sim_spikes_raw_sss.fif) should 
not have bad channels. If there are notable artefacts like spikes or step-like jumps, you may 
need to inspect the original data for determining the bad channels and reprocess the data 
with MaxFilter (see section 13.1). 
Adjust the threshold levels for EOG and ECG artifact rejection. Note that this works only 
when EOG and ECG are included in the datafile, see section 16.5 to ensure ECG-blanking is 
set. Select a time span which contains a beat or two, then select Commands -> Search… -> 
Set ECG. The threshold level for detecting ECG peaks is set to 70% of the maximum signal 
value in the ECG channel within the selected interval.  

• The value is not saved and is updated if a new selection is made and used to set ECG. This 
should be repeated for EOG. 

• After performing the spike search, it may be necessary to evaluate how well the ECG/EOG 
detection worked and adjust as needed. Events categorized with “corrupted-ecg” or 
“corrupted-eog” are rejected because they overlap with ECG and/or EOG events. 

14.3 Create SSP projector for suppression of cardiac signals 

• Observe the ECG signal (bottom panel). 
• If cardiac artifact exists in the data and you wish to suppress it, PCA is provided for this.  
• An SSP projector can be created to suppress the artifact. 

o Select a time selection that clearly represents the artifact (right-click and drag). 
o Select Commands -> PCA on selection.  
o The program produces three PCA choices for 1/3/5 SSP vectors in the SSP Vectors 

window. 
o Select e.g. PCA [306,3] (Figure 64a), apply (->) and inspect the data in the signal displays 

to assess the efficacy of the cardiac signal suppression. 
o Note: The same SSP projection must be applied also in source modelling. However, 

Graph does not transfer the projection together with MEG-EEG data when an epoch is 
transferred to Xfit. Therefore, save the SSP projection to a FIF-file (File -> Save).  

o The SSP saving directory is defined in Parameters -> Misc defaults -> ssp-vector-
directory (default /neuro/ssp). 

o Load the saved SSP vectors in Xfit (Process -> Projection -> File -> Open, Figure 64b).  
o Xfit will keep the vectors for new epochs from the same file if you paint the SSP vectors 

and select Edit -> Set permanent on the Xfit Linear projection dialog. 
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Figure 64: a) Select 3 PCA components for the SSP.   b) Load SSP in Xfit. 

14.4 Automated event search 
 Review the "match” signal 

The “match” signal is used for detection of high amplitude events, typically spike-like activity (see 
Appendix B: Quick reference for Graph Epilepsy setups, 16.6 for details).  

• The spike search setup is configured to calculate the gradient signal power in 14 different 
brain areas. 

• The “match” signal shown in the display is composed of the maximum local absolute average 
values of these signals and is used for triggering in the search. 

• The “match” signal is effective for detection of high amplitude signals in any of the channel 
groups, even those not displayed on the current MEG channel selection.  

• Adjust the trigger level shown in the lower right corner to suitable level using Search... -> 
Threshold... -> up/down 10 %, up/down x2 menu. If there is nothing interesting in the 
current view, scroll through the data, or adjust the level to the maximum of the background 
activity. 

 

Figure 65: The signal and threshold level shown in the “Match” display. The threshold adjustment 
menu is shown on the right. 

 Search for events with spike search 

Spike search is controlled from the tear-off menu Commands -> Search… (see Appendix B: Quick 
reference for Graph Epilepsy setups, 16.4). It contains buttons that are used to define the search 
procedure.  

• Use the right mouse button to select a time point where scanning should begin, select 
Search… -> Set point. 

• Select Search… -> Next match to search for the next event where the “match” signal exceeds 
the current trigger level. Check that this is reasonable.  

• If needed, change the threshold Search… -> Threshold... -> up/down 10 %, up/down x2. 
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Figure 66: “Match” signal with event highlighted after detection. Selecting the “Next match” 
button will select the next trigger event. 

• By default, all channels are included in the search. To select a subset of channels for using in 
the spike search, use Commands -> Search… -> Active areas. Select only the regions of 
interest and de-activate other regions. 

• Use Displays -> xfit… menu to transfer the current data to XFit for spatial viewing and setting 
of the fitting parameters. For description of this menu see “Graph Reference Manual” 
chapter XFit. 

• To list the events that are larger than the threshold, use Commands -> Search -> Collect all 
for the whole file. 

• For specified time windows, use Commands -> Search -> Collect and give specified time 
window for events. 

• The scan can be interrupted using the Cancel button in the working dialog only if the routine 
can find some events. If the trigger level is very high, the whole file would be scanned even if 
Cancel is pressed.  

• When a spike event is found, a classification routine is run. By default the event is labeled 
with symbol :ok , but several other classifications may also appear (Appendix B: Quick 
reference for Graph Epilepsy setups, 16.6). 

• The events are listed in the Search -> Event lists… utility (tagged with :ok). The time point 
recorded is the maximum of the first peak in the data interval that exceeds the limit. 

• Review the events by double clicking them, one at a time, or using the arrow keys and Enter 
to select.  

14.5 Filter and sort events using the event list 

The event list utility provides an editor which allows sorting and filtering the event list (Figure 67).  

• All events detected during the spike search are listed in the primary event list (left column). 
After the spike search, this list can be saved to disk for later study, or a subset of the events 
can be transferred to a filtered event list (right column).   

• In addition, previously saved events can be loaded into the event list by selecting File -> Load 
and selecting a *.evl file. 

• Each line in a list corresponds to one event. It shows the time and amplitude of the trigger 
point and the classification of the event. 

• Selecting the ok-> button sends all events labeled :ok to the Filtered events list.  
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Figure 67. Event lists. 

 

Figure 68: The Filtered events have been sorted by amplitude and the first three in the are selected 
for deletion because they are not suitable events, as seen in the lower right “Match” window. 

• Confirm that the event is a spike or other epileptic activity by viewing the MEG signals. Select 
the events by double clicking them one at a time or using the arrow keys and Enter.  

• The highlighted selection can be transferred to Xfit for review of the field maps or open the 
xfit -> View -> Full view and see the topographical view of the selection. 

• Select Edit -> Sort by amplitude. 
o Examine small and large amplitude events to identify suitable amplitude range for fitting. 
o If the trigger level was slightly too low (many “false positives”), throw away the smallest 

amplitude events by selecting them and pressing Clr button.  
o Examine also the largest amplitudes for possible artifacts. 

When a suitable range of amplitudes is selected, save the event list for documentation, File -> Save 
filtered events, and proceed to dipole fitting.  
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14.6 Classify events 

It may be necessary to classify the events into different categories (with an event tag) if they arise from 
different areas, have differing field patterns or waveforms. This is particularly important if the events 
will be averaged later.  

• Assigning an event tag can be done while marking events manually: Commands -> Search -> 
Manual marking -> Event-A/B/C  

• To change an event tag after spike search to event type A/B/C, double click the event tagged 
with :ok, then select Commands -> Search -> Manual marking -> Event-A/B/C. The event 
type is changed in the All events panel on the left. 

14.7 Average, save and load events 
The event lists allow averaging of filtered events. Note that only events that can be assumed to arise 
from a same source should be averaged, and you should perform event classification before averaging. 

• Review the events and move the good events into the filtered events in Event lists one by 
one or by selecting a list them, then press -> (Figure 69).  

• If more than one event type is listed in the filtered events they will be grouped and averaged 
according to their tag. 

• By default, the averaging window is -100...100 ms with respect to the selected time point.  
• To change this window: Display -> Control panel and double click average-A (and/or B, C) 

widget and change the start/end time.  
• Average the event(s): Event list -> Action -> Average filtered. 
• Review the averaging information window (i.e. number of events).  
• Review the average-A in the Xplotter window (may be behind the Graph window). 
• Save the averages from Event list: File -> Save event averages. 
• Transfer to xfit: Action -> Show average A (or B/C). 

 

Figure 69: Transfer classified events to Filtered events list. 

• To load existing marked events , open the event list: Commands -> Search -> Event lists. 
• In the Event lists window: File -> Load events, select an existing event file (*.evl). 
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14.8 Source modelling on averaged events  

• Use the Xfit connected to Graph or start Xfit: Displays -> xfit -> Start xfit. 
• Create average waveforms from Event lists (see section 14.7) and send to Xfit: Action -> 

show Average-A (or B/C) 
• Alternatively, open a saved averaged file in Xfit: File -> Open and select the data file 

(*_average-A.fif). 
• Select View -> Autoscale. 
• Select the baseline (as explained previously) for reliable confidence volume estimates. 
• Proceed as for fitting a dipole to a single event (Section 8). 

14.9 Fit dipoles to a large list of events 
If you have large number of events in the list, you can do automated dipole fitting on the listed events. 

• Clear the Xfit Dipole Fitting window, right-click and select clear. 
• Press File -> Preferences -> Fitting -> Send fitted dipole automatically to Mrilab. 
• Double-click the first filtered event from the Event lists dialog. 
• Execute Action -> Fit events. 
• Look at the list of fitted dipoles in Dipole fitting window in Xfit. By default, the dipoles are 

fitted every 10 ms from the beginning of event, visible as gray window in Graph or the event 
transferred in Xfit. 

• Change the fitting parameters (as needed) in Graph: Parameters -> Spike-search. Parameters 
search-fit-start and search-fit-end define the window length with respect to the 
defined event, and search-fit-interval defines the interval with which the dipoles are 
fitted. 

• Select Event lists -> Action -> Fit events to fit dipoles for each event in the event list using 
these parameters.  

• The result is a long list of dipoles fitted on the Dipole Fitting window. Select all the dipoles, 
right-click and select Filter in the menu that appears. Use goodness of fit threshold (e.g., 
g > 80%) to filter only the best of the dipole fits. Select the filtered dipoles, right-click and 
select -> MRI to see the dipoles overlaid the MR image.  

• If needed, adjust the event window and dipole fitting parameters, for example, if the spike is 
70 ms long, define a window [-20 0] ms, with respect to the event marker, and fit a dipole 
every 2 ms to fit the beginning of a spike and the peak value, but nothing after the defined 
event marker.  

• Note that here the baseline is not automatically defined, and thus the confidence volume 
estimates are not reliable. 
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15 Appendix A: Installing and tailoring Graph setups 

15.1 Installation of the setups 
The Graph setups require a standard Linux analysis workstation where Data Analysis software release 
3.4 has been installed. The setups described in this manual are automatically installed with the Data 
Analysis Software release 3.4.6 and later. You can inspect the release version from the contents of the 
text file /neuro/setup/Release. If it is older than 3.4.6, you can install the setup files in the following 
way. 

To install the general setups, 
• Open a system terminal: Applications -> System Tools -> Terminal. 
• Login with administrative priviledges and type the following commands 
• cd /neuro 

• tar -xvzf dana-graph-apps-general_setups-1.0.0-bin-1811301450.tar.gz  

Continue with the spike search setups, 
• tar -xzvf dana-graph-apps-epilepsy-2.3.6-bin-1912202127.tar.z 
• tar -xzvf dana-graph-apps-epilepsy-3.3.6-bin-1901141622.tar.z  

• tar -xzvf dana-graph-modules-eeg_caps-1.0.2-bin-1910251541-so.tar.z  
• tar -xzvf dana-graph-modules-montages-1.0.0-bin-1910251630-so.tar.z  
• tar -xzvf dana-graph-modules-spike_search-2.0.0-bin-1901071213-

so.tar.z  

 
• Open file /neuro/app-defaults/Graph-2.94 in a text editor 
• Add the following line (e.g. at the end) and save:  
• #include "Graph_custom"  

After installation, the setup and lisp code files are located in /neuro/lisp/local/graph-2.94/ 
subfolders setup and code.  

15.2 Tailoring the setups 

Any user can tailor the Graph setups and save own versions in directory $HOME/lisp/setup where 
$HOME refers to the user’s home directory. For example, you can save your own version of the 
epilepsy-3.3 setup after setting the EEG cap definition (see section 7.2) and adjusting filters (see section 
13.1.3) into file $HOME/lisp/setup/my-epilepsy-3.3.setup.  

You may need to edit the configuration file “.graph” in your home directory for setting the file path 
for the setup and lisp code files (see the Signal Processor User’s Guide section 3.2). An example of the 
contents of file $HOME/.graph: 

(setq *setup-file-path* (str-append (getenv "HOME") "/lisp/setup")) 
(add-path (str-append (getenv "HOME") "/lisp/code/") :first t) 
(setq graph::max-evoked-data-size 100000000) 
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16 Appendix B: Quick reference for Graph Epilepsy setups 

16.1 EEG configuration  

• Define the EEG cap as described in section 7.2. Available selections are: 
o “Headbox”: 32-channel EEG headbox (part no. NM24116N, Figure 70a).  
o “TRIUX cap”: 32/64/128 channel TRIUX EEG cap (Figure 70b); see NM24405A-* EEG 

Cap User’s Manual.  
o “Easycap”: see the Easycap electrode layouts at www.easycap.de. 
o “Vectorview cap”: older MEGIN caps (part no. NM20884N, NM20885N, NM20886N). 

 

a) b)  

Figure 70. a) 32-channel unipolar head box. Separate electrodes are connected to the pins; 
mapping of channels 1–19 are the same than in the TRIUX EEG cap. Channels 20-32 can be 
connected to other desired electrode locations. b) Layout for the 64-channel TRIUX EEG cap. Yellow 
circles indicate the electrodes in the 32-channel cap. The first 19 channels are the same in the head 
box and in all TRIUX EEG caps. 

16.2 EEG derivations 

• The EEG montages follow American Clinical Neurophysiology Society Guideline 3: A Proposal 
for Standard Montages to Be Used in Clinical EEG [ACNS]. 

• EEG montages are either bipolar montage or referential (Figure 71). Bipolar montages mean 
computing and displaying waveforms of difference between the signals of two channels. The 
referential montage means that the differences are taken between each channel and a 
common reference electrode signal. 

• Bipolar EEG derivations listed in Tables 2-4 are defined in the configuration file 
/neuro/lisp/local/graph-2.94/config/eeg-derivations2.lsp.  
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• This file can be edited to select and modify the preferred EEG montages by a user with 
administrative priviledges:  
o Make a backup copy e.g. to eeg-derivations2.lsp.orig. 
o Copy eeg-derivations2.lsp e.g. to your home directory and modify with a text 

editor. 
o Copy the edited file back to /neuro/lisp/local/graph-2.94/config/eeg-

derivations2.lsp, and verify that the derivations appear correctly. 
• Note that some of these derivations require ear-reference electrodes A1 and A2 which are not 

included in the EEG caps. They can be connected e.g. via the headbox (Figure 70a).   
• If a channel required by a derivative is missing, Graph EEG window does not show anything. 

 
a)

 

b)

 

c)

 

d)

 

Figure 71: Standard bipolar EEG montages according to [ACNS]. a) Longitudinal (double-banana) 
LB-18.1, b): transverse TB-18.1, c) Cz-referential, d) Ear-referential R-18.1. 
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Table 2: Longitudinal bipolar EEG montages according to [ACNS]. 

Channel LB-18.1 LB-18.2 LB-18.3 
1 Fp1 F7 Fz Cz Fp1 F7 
2 F7 T7 Cz Pz F7 T7 
3 T7 P7 Fp1 F3 T7 P7 
4 P7 O1 F3 C3 P7 O1 
5 Fp1 F3 C3 P3 Fp2 F8 
6 F3 C3 P3 O1 F8 T8 
7 C3 P3 Fp2 F4 T8 P8 
8 P3 O1 F4 C4 P8 O2 
9 Fz Cz C4 P4 Fp1 F3 

10 Cz Pz P4 O2 F3 C3 
11 Fp2 F4 Fp1 F7 C3 P3 
12 F4 C4 F7 T7 P3 O1 
13 C4 P4 T7 P7 Fp2 F4 
14 P4 O2 P7 O1 F4 C4 
15 Fp2 F8 Fp2 F8 C4 P4 
16 F8 T8 F8 T8 P4 O2 
17 T8 P8 T8 P8 Fz Cz 
18 P8 O2 P8 O2 Cz Pz 
19 ECG   ECG   ECG   

      
 

 

Table 3: Transverse bipolar EEG montages according to [ACNS3]. 

Channel TB-18.1 TB-18.2* 
1 F7 Fp1 Fp1 Fp2 
2 Fp1 Fp2 F7 F3 
3 Fp2 F8 F3 Fz 
4 F7 F3 Fz F4 
5 F3 Fz F4 F8 
6 Fz F4 A1 T7 
7 F4 F8 T7 C3 
8 T7 C3 C3 Cz 
9 C3 Cz Cz C4 

10 Cz C4 C4 T8 
11 C4 T8 T8 A2 
12 P7 P3 P7 P3 
13 P3 Pz P3 Pz 
14 Pz P4 Pz P4 
15 P4 P8 P4 P8 
16 P7 O1 O1 O2 
17 O1 O2 Fz Cz 
18 O2 P8 Cz Pz 
19 ECG   ECG   

     *If A1 and A2 are included 
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Table 4: Referential EEG montages according to [ACNS3]. 

Channel R-18.1 R-18.1* 
1 F7 Cz F7 A1 
2 T7 Cz T7 A1 
3 P7 Cz P7 A1 
4 Fp1 Cz Fp1 A1 
5 F3 Cz F3 A1 
6 C3 Cz C3 A1 
7 P3 Cz P3 A1 
8 O1 Cz O1 A1 
9 Fz Cz Fz A1 

10 Pz Cz Pz A2 
11 Fp2 Cz Fp2 A2 
12 F4 Cz F4 A2 
13 C4 Cz C4 A2 
14 P4 Cz P4 A2 
15 O2 Cz O2 A2 
16 F8 Cz F8 A2 
17 T8 Cz T8 A2 
18 P8 Cz P8 A2 
19 ECG   ECG   

     *If A1 and A2 are included 
 

• If you prefer to use the nomenclature terms T3/T4/T5/T6 instead of the modified 10-10 
terminology T7/T8/P7/P8, make the following substitutions in eeg-derivations2.lsp: 
T7 -> T3  
T8 -> T4  
P7 -> T5  
P8 -> T6 

16.3 Displays menu 

• Select Displays->Views, left-click on the dashed line at the top of the sub-
menu, and place the tear-off menu position at a convenient location. The 
menu in epilepsy-2.3 setup has first channel selections: 

View temporal 
Pressing this button selects channels from the temporal areas to be 
displayed on the right-hand side displays. 

View parietal 
Pressing this button selects channels from the parietal areas to be 
displayed on the right-hand side displays. 

View frontal 
Pressing this button selects channels from the frontal areas to be display 
on the right-hand side displays. 

View occipital 
Pressing this button selects channels from the occipital areas to be display on the right-
hand side displays. 
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• The remaining choices in the menu are common to both epilepsy setups: 

Scroll 
Scroll data forward automatically until the data ends or user stops the scrolling by pressing 
the Stop button on the working dialog that is shown during the operation. 

Go to... 
Move the view to start from given time. Pressing this button will pop up a small dialog that 
asks the starting time. Pressing the OK will move the view to given time point. 

Length... 
Change length of the displays. The default length is 5 seconds. This button pops up a dialog 
that allows the change of the length of all the displays. 

Default scales 
Change the scales of all displays to default settings. Default values for different kinds of 
channels are defined in the parameter set displays. See “Parameters” below. 

Bigger 
Change the scale of the displays so that the signals look bigger. To select some channels 
use the right mouse button and click a curve or drag over a range of curves. To deselect 
channels, click on the narrow dark border of the display outside the curve viewing area. 

Smaller 
Change the scale of all selected displays so that signals look smaller. 

Remove bad 
Remove selected MEG signals from being viewed or used in analysis. Click first the signal 
that looks bad on the right-hand side window to select it (check that there are no other 
curves selected) and press this button. The selected curve should disappear from the 
displays and a flat signal with no name should appear on the bottom of the channel by 
channel display. 

View all 
View all channels, that is, no channel is marked as bad channel any more. 

Chop 
Make an evoked format data file from the data in the current time selection on the display. 

• Select Parameters->Displays to adjust parameters that affect the displays:  
meg-amplitude 

This defines the default amplitude for MEG displays. When 
the Default scales button is selected from the Views menu, 
this value will be used in MEG displays. 

eeg-amplitude 
Default value to be used in scales for EEG displays. 

eog-amplitude 
Default value to be used in EOG displays. 

ecg-amplitude 
Default value to be used in ECG displays. 

scroll-delay 
Scroll delay. When the scroll command is activated from the views menu, there will be a 
delay of this many seconds before next search is activated. 
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16.4 Search menu  

• The Commands -> Search menu has the following buttons: 

Set point 
Set search start point. Before first search, you should define the 
starting point for the search. Select first one time point (using the 
right mouse button) and then press this button to select this time 
point as the start point for the searches. After a search for the next 
event, the next starts from the previous event found plus some 
minimum step that can be defined. See “Parameters of the search” 
below. 

Next match 
Scan trigger channel until a new peak exceeding the trigger level 
appears. The view on the display is moved so that the trigger point is 
visible, and the time selection is set so that it shows the time interval 
that would be transferred to fitting program. The scan returns only 
events that are classified as “ok”. 

Clear event list 
Clear all entries from the event lists. See “Event lists” below. 

Collect all events 
Scan the whole file for all events and collect the found events into the event list. 

Collect events within 
Search some interval of data, and add the events found in it to the event list. Pressing this 
button pops up a dialog that asks for the start and stop time for the scan. 

Save event list 
Save current event list into a file. Pressing this button pops up a file selection dialog where 
you should enter the name of the file where to save the list. The data is saved as textual 
LISP object. 

Event lists... 
Pop up the display list editor dialog. 

Fit 
Fit the last found event. This is used in interactive mode, where one manually asks program 
to proceed to next event, and it this looks good, one can fit dipoles to the data around the 
spike by pressing this button. Before applying this operation, the source modeling program 
(Xfit) should be started from the xfit menu. 

Fit to end 
Fit all the rest of the events. When one has examined some candidate events using the 
Next match and Fit buttons, and the trigger level is set to correct value, one can proceed 
to fit all the rest of the events by pressing this button. This will fit all events automatically 
labeled with :ok. Collecting all events first to an event list and then performing the fitting 
is preferred over usage of this button, since the event lists provide more flexibility and 
better documentation on what was selected into the fitting. 

Up 2x 
Increase the trigger search threshold level by factor of 2. 
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Up 10% 
Increase the trigger search threshold level by 10%. 

Show threshold 
Show current threshold, e.g. for documenting the trigger level used in the search. 

Down 10% 
Decrease the trigger search threshold by 10%. 

Down 2x 
Decrease the trigger search threshold by factor of 2. 

Set ECG 
Set the threshold level for ECG artifact rejection. Select first a time span which contain a 
beat or two, and then press this button. The threshold level for detecting ECG peaks is set 
to 70% of the top signal value in the ECG channel within the selected interval. 

Set EOG 
Set the threshold level for EOG artifact detection level. Works in similar fashion as the Set 
ECG button, except that it uses the EOG channel instead of ECG channel. 

16.5 Parameters of the search 
Parameters affecting the searching operations are defined in the parameter set spike-search 
in the Parameters menu. The parameters are as follows:  

search-trigger-source 
Name of the widget from which the trigger signal is 
taken for the search. This must be a widget that supplies 
a proper trigger signal in its first channel. If you are using 
this with the setup provided with this utility, you should 
not change this value. 

search-threshold-widget 
Name of the widget performing the thresholding of the 
trigger signal. Do not change this parameter unless you 
have a custom setup. 

search-initial-jump 
Initial time leap in the beginning of each search to 
prevent double fitting of events very near each other. 
Suitable value for this is the length of the fitting interval 
(see below). 

search-ecg-blanking 
Minimum time distance from a trigger point to nearest ECG signal. If this value is e.g. 0.2, 
this means that if there is large signal in the ECG channel (over the ECG threshold) nearer 
than 200 ms from the trigger point, this trigger point will be labeled as :corrupted-
ecg instead of :ok. If you do not want to use the ECG blanking you can set this parameter 
to nil. If your data does not have a proper ECG channel, you must set this parameter to 
nil in order to use the search. 
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search-eog-blanking 
Minimum distance to nearest EOG event. Similar to search-ecg-blanking. Use nil 
if no EOG blanking is required. If there is a strong EOG signal near to the trigger point, the 
event will be labeled as :corrupted-eog. 

search-meg-blanking 
Minimum distance to nearest MEG artifact. The MEG artifacts are detected from the 
trigger signal by using a threshold level higher than the threshold level used for the spike 
detection. If this higher threshold level is exceeded near the trigger point, then the event 
is classified as :corrupted-meg. 

search-fit-restrict 
This parameter is currently not used. 

search-fit-start 
Define the staring time for fitting dipoles. Time is in seconds and relative to the trigger 
point. 

search-fit-end 
Define the end time for dipole fitting. Time is in seconds and relative to the trigger point. 

search-fit-interval 
Dipole fitting density. Dipoles will be fitted starting from the beginning of the fitting region 
in steps defined by this parameter. Steps are in seconds. 

16.6 “Match” signal spike searching 
The gradiometer properties can be utilized efficiently for searching spike-like activity. Denoting the 
signals of a single triple-sensor unit by Bz (magnetometer), ¶Bz/¶x (latitude gradient) and ¶Bz/¶y 
(longitude gradient), the gradient magnitude (or power) is obtained from the gradiometer pairs as 
(¶Bz/¶x)2 + (¶Bz/¶y)2. Information compression is obtained by dividing the 204 gradiometers into 14 
groups according to anatomical locations, each having 8 – 12 gradiometer pairs. The gradient powers 
of the associated sensor pairs are summed and the “Match” waveform shows at each timepoint the 
maximum value among the 14 channel groups. 

MEG gradiometer data is scanned until the match signal power exceeds a predefined threshold level, 
after which it continues to the first peak top in the data. This time point is returned as the time point 
of the current event. This time point is then labeled using the following considerations: If the time 
distance from the point to the nearest ECG signal (exceeding the ECG threshold level) is less than ecg-
blanking time, this event is labeled as :corrupted-ecg. Similarly if there is large EOG signal within 
eog-blanking time, event is labeled as :corrupted-eog-1 or :corrupted-eog-2, depending 
on which EOG channel did cause the condition. If the event is so near beginning or end of the data that 
either of the blanking time would go beyond the existing data, event is labeled as :too-near-edge. 
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16.7 Adjusting the setups 

The part which is most likely to vary from site to site is the usage of the EEG channels. It is unlikely that 
the default settings would match your needs. The following things should be taken into consideration. 

Adjusting EOG channels 
If EOG channels are not used, set the eog-blanking to nil in the search parameters. 
Otherwise open the control panel and double click the “eog” widget icon. Modify the channel 
definitions in the editor box so that the electric channels used to measure EOG are selected. 
Only the first two channels are used, if more than two channels are selected. 

Adjusting ECG channels 
If ECG is not measured, set the ecg-blanking to nil in search parameters. Otherwise set 
the channel name in the “ecg” widget to pick the electric channel used to measure the ECG 
signal. 

Adjusting EEG channels 
The setup shows 20 EEG channels on the display and uses the derivation-menu module to 
enable forming of various easily selectable derivations. You need to define the derivations that 
are needed in your EEG cap. For instructions see reference pages for the derivation-menu 
module. 

16.8 Event-list dialog 

• File menu in the event-list dialog (Figure 67) contains following buttons: 

Save all   Save events in the left hand side list. 
Save filtered   Save events in filtered event list. 
Load   Load events from a file into the left hand side list. 
Close   Close the dialog. 

• Edit menu contains the following buttons: 

Sort by time  Sort events in the filtered list by event time. 
Sort by amplitude Sort events in the filtered list by the event amplitude. 
Clear all  Clear all events from both event lists. 

• Action menu contains the following buttons: 

Collect all events Scan all data and add found events into the complete event list. 
Collect events within... Popup a dialog to define the time limits between which the events 
   are scanned. When the dialog is closed by pressing OK, given time 
   interval is scanned and events found are added into the complete 
   event list. 
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17 Revision history 
Revision A 

• Company name change (Megin Oy). 
• Scope TRIUXTM and TRIUXTM neo customer training. 
• Improved flowchart figures. 
• Reordered the contents to basic MEG analysis workflow and separate advanced steps. 
• Added more information on Graph setup installation and tailoring, and EEG montages. 

Revision B 
• Inspection and correction of the head position, section 4.4 and Chapter 10. 
• Graph setups are included in DANA software release 3.4.6, section 14.1. 
• Note about avoiding mixing files of different patients, section 4.6. 

Revision B1 
• Company address change. 
• Added symbols on the equipment as Ch 1. 

 


